Questão conflito textlive-bibtex-extra e biber


Esta é uma nova instalação do Kubuntu 16.04 com todas as últimas atualizações aplicadas.

Eu instalei todo o texlive: apt install texlive\* e então tentei instalar o biber: apt install biber que quer remover o texlive-bibtex-extra. Tentando instalar os dois juntos: apt install biber texlive-bibtex-extra dá o seguinte erro:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
texlive-bibtex-extra is already the newest version (2015.20160320-1).
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 texlive-bibtex-extra : Breaks: biber (< 2.4) but 2.3-1 is to be installed
E: Unable to correct problems, you have held broken packages.

Alguém tem alguma idéia de por que o pacote biber está desatualizado com a dependência texlive-bibtex-extra?

Eu sei que posso pegar a distribuição texlive diretamente, mas eu gostaria de usar o gerenciador de pacotes, se possível.


14
2018-04-24 18:49


origem




Respostas:


Com base nisso relatório de erro, parece que o que você encontrou (e o que eu acabei de encontrar) é um bug que não foi consertado a tempo para o 16.04.

Alguém nessa página sugeriu uma solução alternativa que envolve o download do biber da fonte. Você pode considerar isso até que seja finalmente consertado?

(Apenas tentei por mim mesmo e confirmei que funciona.)

(Edit: Note que parece (o mais velho) biber versão 2.4 deve ser usado. Uma versão mais recente não parece compatível com o biblatex que vem com o Ubuntu 16.04)


10
2018-04-25 02:55



Obrigado por encontrar o bug, eu deveria ter continuado a cavar :) Vou compilar a partir da fonte até que o bug seja corrigido. - fraktur3d
Não há necessidade absoluta em construir o biber a partir de fontes: os binários do SF funcionaram para mim sourceforge.net/projects/biblatex-biber/files/biblatex-biber/… - Artem Pelenitsyn
Este foi corrigido ontem (2016/06/28); agora você pode instalar diretamente biber (instalará a versão 2.4). Vejo bugs.launchpad.net/ubuntu/+source/biber/+bug/1589644/comments/… - Rmano