Questão Pacotes não estão instalando!


Eu estou tentando instalar pacotes usando apt-get

Estes são os seguintes pacotes:

root@ubunto:/# sudo apt-get install build-essential libssl-dev libcurl4-gnutls-dev libexpat1-dev gettext unzip
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package libcurl4-gnutls-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Unable to locate package build-essential
E: Unable to locate package libssl-dev
E: Package 'libcurl4-gnutls-dev' has no installation candidate
E: Unable to locate package libexpat1-dev
E: Unable to locate package gettext
E: Unable to locate package unzip

Meu objetivo principal é instalar o pacote make , que eu preciso instalar manualmente uma versão inferior do PHP

Isso é o que aconteceu:

root@ubunto:~/php-5.4.31# make
The program 'make' is currently not installed. You can install it by typing:
apt-get install make

E então eu continuo e faço 'apt-get install make'

root@ubunto:/# apt-get install make
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package make is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'make' has no installation candidate

Estou executando o Ubuntu 14.04.1 LTS em uma máquina virtual (Hyper-V) se isso ajudar


2
2017-07-31 20:28


origem


Por favor anexe a saída de lsb_release -d Para sua pergunta, os backports que você mencionou em seus comentários tendem a dizer que você está executando 13.04, não 14.04. - Sylvain Pineau
possível duplicata de O que o pacote <pacote> não tem candidato a instalação significa? - Parto
possível duplicata de Como instalar software ou atualizar a versão antiga não suportada? - Sylvain Pineau
@SylvainPineau ok então o real era o Ubuntu 14.04.1 LTS - user3170899
ok, obrigado pela confirmação. Então você pode ter um quebrado sources.list, Olhe para Como faço para restaurar os repositórios padrão? maneiras de restaurar suas configurações de origem - Sylvain Pineau


Respostas:


Eu tive o problema de pme apenas antes de alguns dias. Tente correr

# apt-get update

Seu apt-repository está desatualizado. Esse pode ser o problema.


2
2017-07-31 20:33



aqui é outro problema que eu acho: quando eu faço o apt-get update ele instala apenas algumas das atualizações, mas não todas, eu estou pensando que este é o problema? Estou usando o sudo su - user3170899
este é o erro: Err us.archive.ubuntu.com raring-backports / main i386 Pacotes 404 Not Found [IP: 91.189.91.15 80] (o Ubuntu pode estar inoperante ???) (existem muitos mais com os mesmos erros que estão sendo postados, por exemplo) - user3170899
Ok, o código de erro 404 é como o meu. Eu não sei agora por que existem fontes de backing-backing. Tente $ ping -c 2 91.189.91.15 - LittleByBlue
Sem gotas 0% de perda de pacotes, o tempo foi de 1007 ms - user3170899
isso não é um comando. Ele queria ir para esse site, baixar o .deb e usar dpkg -i /path/to/downloaded.deb para instalá-lo - ElefantPhace