Questão Como instalar o Gala no Xubuntu 14.04?


Eu tentei instalar o gerenciador de janelas Gala (o gerenciador de janelas do Elementary OS) no Xubuntu 14.04 como descrito por exemplo Aqui, mas parece que há uma dependência não atendida. O erro é

The following packages have unmet dependencies:
gala : Depends: libmutter0d  3.12.2-1ubuntu99~elementary0.3.4) but it is not installable
E: Unable to correct problems, you have held broken packages.

Eu também instalei o libmutter0d pacote, mas o erro persistir. Existe algo que eu possa fazer para superar isso?

Como o beta1 da nova versão do Elementary (baseado no ubuntu 14.04) é testável, outra opção seria instalar a versão beta do gala. Não tenho certeza se é possível, mas sim, quais são os passos necessários para isso?


2
2017-08-16 12:18


origem


possível duplicata de Como resolvo dependências não atendidas? - Parto
Nenhuma solução encontrada lá. Gala parece ser instalável no Ubuntu versões 13.10 apenas para baixo. - user47224


Respostas:


resolvido com

sudo apt-add-repository ppa:elementary-os/testing
sudo apt-get update

então a versão certa do libmutter0d está lá


2
2017-08-16 17:45



Desta forma, Gala pode ser instalado, mas se eu iniciar, dois erros aparecem e ele falha: "Erro libGL: falha ao autenticar magic 1" e "erro libGL: falha ao carregar driver: vboxvideo". Não sei se eles estão relacionados apenas à sessão do Xbox ou se o pacote não funciona corretamente. - user47224
@ user47224 Eu suspeito que o problema não esteja relacionado à dificuldade original de instalá-lo. Você pode postar uma pergunta separada para perguntar sobre isso. - Eliah Kagan