Questão Unity não carrega, não é iniciado nem aparece Dash


Quando eu faço login, nada acontece.

Eu sou apresentado com o meu papel de parede.

Blank desktops suck

Sem Dash, sem Launcher, nada.


535
2017-12-14 17:24


origem


IMHO isso é um bug, mas eu tenho isso desde hoje. Poderia encontrar apenas esse bug bugs.launchpad.net/ubuntu/+source/unity/+bug/1212987 Eu segui as recomendações aqui: askubuntu.com/questions/17381/… A unidade foi redefinida, mas não está funcionando OK, os espaços de trabalho não funcionam, mesmo se eu ativar ou desativar ou alterar o valor. Nenhuma diferença Coloque o plugin também trava a unidade, - Janghou
Meus problemas começaram depois de mudar de drivers nouveau para drivers NVIDIA (configurações do sistema / guia hardware). - DanielaWaranie
Depois de muitos dias gastos e muitos tópicos SO lidos, descobri que isso parece ser um Bug aberto do Ubuntu (Status 'Incomplete' de julho de 2015). Mais informações sobre isso aqui: bugs.launchpad.net/ubuntu/+bug/1285444  A solução rápida parece ser: $ mv ~/.config/dconf/user ~/.config/dconf/user.old - xyz
@ Julianromera foi a única solução neste segmento que me ajudou - Dziamid
A resposta do @julianromera foi a única que funcionou para mim. - Paweł Adamski


Respostas:


Esta resposta aplica versões do Ubuntu rodando o Compiz.

Esta resposta assume que o Unity está sendo executado através do Compiz. Se você não tem compiz instalado esta resposta não se aplica a você.

Você só precisa ativar o plug-in do Unity. O problema é que isso é uma dor no fundo porque você não tem nenhum método gráfico para fazer isso. Assim:

  1. Tente abrir um terminal com Ctrl+Alt+T.
    Isso pode não funcionar, mas você pode tentar clicar com o botão direito do mouse na área de trabalho e selecionar "Abrir terminal aqui". Caso contrário, pode ser necessário mudar para um terminal "rígido" pressionando Ctrl+Alt+F1 e faça o login.

  2. Instalar compizconfig-settings-manager Correndo

    sudo apt-get install compizconfig-settings-manager
    
  3. Em seguida, execute-o com isto:

    DISPLAY=:0 ccsm &
    

    A primeira parte diz ao terminal qual display você quer que ele carregue (caso contrário, ele não terá uma pista).

  4. Se você mudou para um TTY no passo 1, volte para o servidor gráfico pressionando Ctrl+Alt+F7 (ou Ctrl+Alt+F8 as vezes).
    Deve haver um Gerenciador de Configurações CompizConfig esperando por você.

  5. Encontre o plugin do Unity. Habilitá-lo. Você será perguntado "Plugin do Ubuntu Unity requer o plugin OpenGL. Habilitar Plug-in do Unity do Ubuntu / Habilitar OpenGL"

  6. Tudo deve nascer, mas se isso não acontecer, você pode ter que recomeçar. Você pode fazer isso voltando ao terminal e rodando sudo reboot.


465
2017-11-07 23:23



Trabalhou perfeitamente bem para mim. Como uma nota lateral, eu não precisei entrar no terminal TTY, pude usar o atalho do terminal (ctrl + alt + t). - Tass
Se você chegar na etapa 5 e não encontrar unidade na lista, tente o seguinte: sudo apt-get -f install && sudo apt-get --reinstall install unity - Collinux
Tive esse problema, mas eu sou infeliz com a solução agora, não funciona para mim, ainda obter a mesma tela vazia no Ubuntu 14.04 LTS 64 bits. Vai passar por cima dos passos novamente para verificar se alguma coisa foi perdida. Lenovo X201S Thinkpad i7 2.0Ghz 8 Gb de RAM. Nunca tive esse problema com 12.04 LTS - therobyouknow
O fato de que este é um problema tão comum e duradouro é, para mim, bastante perturbador. Alguém sabe por que isso continua acontecendo e o que está causando isso? - fouric
ccsm trava em ícones de carregamento, mas se eu ctrl-alt-F7 voltar para a tela principal, as opções compiz estão lá. Eu habilitei o desktop do Unity, mudei de volta para o tty1 (o ccsm foi executado com sucesso) ... mas não o Unity. Reinicie: não há unidade. Se eu recarregar o ccsm, o Unity ainda está selecionado e "ligado", mas não aparece o Unity. - JeanSibelius


Uma solução boa para mim (resolveu o mesmo problema):

em um terminal:

export DISPLAY=:0   
sudo dconf reset -f /org/compiz/

e depois

setsid unity

166
2018-05-04 00:50



Fantástico. Funciona com o Ubuntu Linux 13.04 Desktop em Parallels no Mac OS X. - Elliot
Obrigado! Funciona com o Ubuntu 14.04 também. Eu me pergunto por que isso aconteceu fora do azul embora :-( - Sadi
eu precisei export DISPLAY=:0 primeiro. - Uri
sudo dconf reset -f / org / compiz / Erro ao gerar linha de comando 'dbus-launch --autholaunch = c0c0f8bf86119c64ccb710000000006 --binary-syntax --close-stderr': processo-filho encerrado com o código 1 - JeanSibelius
Um problema com isto é que correr dconf Como sudo fez o meu ~/.config/dconf/user arquivo tem root propriedade (tinha a propriedade do meu usuário antes). Eu estou querendo saber se deve ser feito sem sudo. Isso foi muito melhor do que remover o arquivo e começar do zero! - Tim Tisdall


Em 13.04 e 14.04:

unity --replace está obsoleto. Em vez disso, use o seguinte:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

Reinicie se não funcionar imediatamente.


72
2018-04-27 02:39



Isso funcionou para mim depois de instalar os drivers apropriados para a minha placa gráfica Nvidia. Veja minha resposta askubuntu.com/questions/288235/… - Thomas Arildsen
dconf reset comando dá erro exitcode 1 e não vai funcionar em 13.10. - Peterdk
ativar plug-ins do Unity com ccsm corrigidos alguns dos problemas, o resto foram corrigidos com rm -r .Xauthority .ICEauthority .compiz-1/ .gconf/ .config/compiz-1/ .config/dconf/ - precise
Não é possível auto-carregar o bus D sem X11 $ DISPLAY. Nada funcionou até agora - jimifiki
Ele funciona para o Ubuntu 16.04 também, apenas resolveu meu problema - Priyadarshi Paul


Para 12.10 e abaixo:

pressione Ctrl+Alt+T para um terminal e execute ccsme reative seu plug-in 'Unity'.

Você também pode precisar executar um unity --replace.


60
2017-10-02 02:33



unity --reset está obsoleto agora e não funciona. Existe um substituto? - Shahbaz
@ Shabaz - unity --replace. - horIzoN
@ nerof61 também depreciou a partir de 13.04. Veja minha resposta abaixo: askubuntu.com/a/286349/2638 - Brandon Bertelsen
nem --reset nem --replace trabalhei para mim com o meu Ubuntu 12.04 .. executando os comandos instantaneamente exibidos unity-panel-service: no process found Backend : ini Integration : true Profile : default Adding plugins Initializing core options...done ... eu esperei e esperei, e depois não consegui, interrompi com ctrl + c .. e agora tentei tentar o que outras respostas sugeriam .. - precise


É uma boa idéia verificar se o seu driver gráfico está configurado para usar a aceleração de hardware e está configurado para usar o OpenGL. Tente pesquisar em Fóruns do Ubuntu e do Ubuntu para obter informações específicas sobre suas GPUs e o sabor do Ubuntu. Para usuários de gráficos híbridos, consulte a última seção "Gráficos híbridos" abaixo.

Você pode querer executar o compizconfig-settings-manager  Install compizconfig-settings-manager pacote e certifique-se de que o plugin Unity está marcado (veja Quais são alguns dos problemas com o CCSM e por que eu gostaria de evitá-lo?).

Para 12.04 e mais recentes

  1. Mudar para tty1 pressionando Ctrl+Alt+F1 e faça o login.

  2. Instalar compizconfig-settings-manager Correndo

    sudo apt-get install compizconfig-settings-manager
    
  3. Em seguida, execute-o fazendo isso:

    export DISPLAY=:0
    ccsm
    

    A primeira parte diz ao terminal qual display você quer que ele carregue (caso contrário, ele não terá uma pista).

  4. pressione Ctrl+Alt+F7 (ou Ctrl+Alt+F8 às vezes) para voltar ao display gráfico onde deveria haver uma tela do Gerenciador de Configurações CompizConfig.

  5. Encontre o plugin do Unity. Habilitá-lo. CCSM

  6. Tudo deve nascer, mas se isso não acontecer, você pode ter que recomeçar. Você pode fazer isso voltando para tty1e correndo sudo reboot.

Se a unidade ainda não carregar tente:

dconf reset -f /org/compiz/
unity --reset-icons &disown

Reinicie se não funcionar imediatamente.

Para 11,10 e mais velhos

Se você espera em um TTY (Ctrl+Alt+F1 através F6) e corra:

DISPLAY=:0 unity --replace

Ele irá redefinir o Unity de volta no TTY 7 (Ctrl+Alt ++F7).

Você também pode tentar apenas:

DISPLAY=:0 unity

Mas isso não vai funcionar se um gerenciador de janelas já estiver rodando no display 0 (ele vai te dar um erro, é só usar unity --replace nesse caso).

Se a unidade absolutamente recusa-se a reiniciar tente isto:

Instalar gnome-panel:

sudo apt-get install gnome-panel

Do que executá-lo no visor 0:

DISPLAY=:0 gnome-panel

Você deve então ter painéis de estilo do Gnome 2 em sua área de trabalho, os quais você pode usar para fazer logout.

Gráficos Híbridos

Algumas informações muito úteis e leituras adicionais para usuários gráficos híbridos podem ser encontradas Aqui.

Quando as GPUs estiverem configuradas adequadamente para aceleração 3D e OpenGL, você poderá:

  1. Instale os drivers da Nvidia de https://edge.launchpad.net/~xorg-edgers/+archive/ppa:

    sudo apt-add repository ppa:xorg-edgers/ppa
    

    ou:

    Eu realmente preferiria o PPA estável, mas não parece ter pacotes para 13.04 ainda. Update: estes parecem estar disponíveis a partir de 25 de setembro. Eu instalaria este PPA estável - você pode tentar, mas eu não testei.

    Os drivers Nvidia fornecidos pelo Ubuntu já estavam instalados e eu simplesmente instalei deste PPA adicionando-o e fazendo uma atualização de pacote usando update-manager.

    sudo apt-add repository ppa:ubuntu-x-swat/x-updates
    
  2. Instale o Bumblebee de https://launchpad.net/~bumblebee/+archive/stable

    ATUALIZAÇÃO: A partir de 6 de outubro ppa:xorg-edgers/ppa parece conter zangão também. Então, se você instalar a partir deste PPA, você pode tentar pular a adição do Bumblebee PPA e instalá-lo aqui.

    Se você escolheu o PPA estável na etapa 1, instale o PPA estável da Bumblebee da seguinte maneira:

    sudo apt-add-repository ppa:bumblebee/stable
    
  3. ATUALIZAÇÃO: Depois de adicionar o (s) PPA (s), atualize suas listas de pacotes:

    sudo apt-get update
    

    Se você já possui drivers nvidia instalados a partir dos repositórios padrão do Ubuntu, basta atualizar para obter a nova versão do repositório escolhido na etapa 1:

    sudo apt-get upgrade
    sudo apt-get install bumblebee
    
  4. Execute os seguintes comandos para 'reparar' Unity (de brandon-bertelsenresposta para Unity não carrega, não é iniciado nem aparece Dash):

    dconf reset -f /org/compiz/
    unity --reset-icons & disown
    

51
2017-12-27 12:45



Em 14.10: unity --reset-icons & disown me dá uma parada: Emprego desconhecido: unity-panel-service // start: Emprego desconhecido: unity-panel-service // compiz (core) - Info: Carregando plugin: core // compiz (core) - Info: iniciando plugin: core ... e nenhuma ação adicional. Alt-F7 me leva de volta ao gráfico, onde eu tenho um menu lateral, mas não "start" menu (nada no menu superior - sem ícone de conectividade, ícone de energia, etc. - volta para tty1 me dá telas e telas de informação. .. reinicie e eu estou DE VOLTA AOS NEGÓCIOS! OBRIGADA PELO SEU VOODOO MÁGICO - JeanSibelius
Sua seção "Para 12.04 e mais recente" não funciona no Ubuntu 16.04. - Luís de Sousa
apt-add-repository? - ausência de - Kalpesh Soni


A maneira mais fácil de fazer isso é pressionar Ctrl+Alt+T para obter um terminal e, em seguida, emitir:

rm -rf ~/.compiz-1 ~/.config/compiz-1

e sua sessão de união voltará diante de seus olhos.

Esta técnica é melhor do que relançar o ccsm, porque você pode entrar na condição de erro do OP sem mesmo desindicionar acidentalmente a unidade no ccsm; você pode obtê-lo simplesmente pressionando acidentalmente o botão "Preferências" no ccsm.


32
2017-11-10 05:55



acho que você quer dizer .config / compiz-1 - matteo
Eu não posso usar ctrl-alt-T - jimifiki
@jimifiki: pressione 'crtl' + 'alt' + 'f1' e então faça o que achiang sugeriu. embora pessoalmente eu os movesse para fora do caminho, caso você encontrasse mais problemas. - isaaclw
@isaaclw Eu fiz o que sugere. Nada mudou. Notavelmente, a sessão de convidado funciona normalmente. - jimifiki
Para o meu Ubuntu 16.04, os arquivos relevantes para remover estavam em .cache, não .config. assim rm -rf ~/.cache/compizconfig-1 trabalhou para mim. - tparker


Eu tive esse problema também. Eu resolvi isso com a exclusão do conteúdo do arquivo ~ / .config / compiz-1 / compizconfig e o relog.

rm -rf ~/.config/compiz-1/compizconfig/*

25
2017-10-30 06:23



não funcionou para mim, praticamente como tudo nesta página - matteo
Sim! Obrigado, funcionou! Eu tenho Ubuntu 16,04 instalado no VirtualBox e depois de uma das atualizações eu tenho esse problema. Esta é a única solução que funcionou para mim! Ah, e não se esqueça de reiniciar depois de aplicar essa correção. - informatik01
Não funciona no Ubuntu 16.04. - Luís de Sousa
Não funcionou para mim em 16.04 - 43Tesseracts
Para o meu Ubuntu 16.04, os arquivos relevantes para remover estavam em .cache, não .config. assim rm -rf ~/.cache/compizconfig-1 trabalhou para mim. - tparker