Questão A instalação do UEFI 13.04 no Lenovo IdeaPad Y510p inicializa o Windows


Eu estou tentando instalar o Ubuntu 13.04 de 64 bits em um Lenovo IdeaPad Y510p. Esta máquina é pré-instalada com o Windows 8, que eu quero manter (a máquina é parcialmente um console de jogos).

Reduzi a partição pré-instalada do Windows em 256 GB para liberar espaço para o Linux e inicializei a partir do DVD de instalação do Ubuntu. Inicialmente houve um problema de tela preta, mas adicionar 'nomodeset' às opções do kernel corrigiu isso. O disco de instalação então inicializado em seu ambiente normal do Ubuntu. Eu selecionei "Instalar o Ubuntu ao lado do Windows 8" e tudo correu bem até que chegou a hora de retirar o disco e reiniciá-lo.

Neste ponto, os menus de inicialização F2 (full BIOS) e F12 (menu de inicialização) exibem tanto "Windows 8" quanto "Ubuntu" como opções de inicialização UEFI, além das opções de inicialização de rede IPv4 e IPv6. O Windows 8 aparece primeiro, depois o Ubuntu, depois a inicialização pela rede. Tanto é razoável; a questão é que selecionando Ubuntu inicializa o sistema no Windows.

O próprio Windows ainda inicializa bem. O Disk Management revela partições recém-criadas de 248.27GB e 7.73GB no espaço anteriormente vazio, que eu suponho ter sido criado pelo instalador do Ubuntu; isso parece bem. Seguindo o comentário de slangasek Aqui, Eu tenho não desative a Inicialização Segura ou tente colocar o sistema no modo Legacy BIOS, já que aparentemente parece que o Secure Boot através do UEFI funciona. Mas se há uma maneira de inicializar a instalação do Ubuntu que acabei de fazer, não consigo encontrá-lo.

Algum conselho?


4
2018-06-25 19:37


origem


Quanto ao seu problema de tela preta, eu tive o mesmo problema ao usar o live CD e acontece que o 'brilho da tela' está ajustado para zero. Se você está enfrentando o mesmo problema, apertar Fn + UpArrow deve abrir sua tela.
A correção com Fn + Up Arrow (em uma tela preta com o live CD) funcionou para mim! (no Lenovo IdeaPad Y510p, Ubuntu 13.04 (Desktop)) - Anton Petrov
hey ystael Eu tenho o mesmo laptop que você Ideapad y510p e não consigo encontrar a opção de inicializar o dvd do Ubuntu, no menu de opções de inicialização eu tenho windows network ipv4 e rede ipv6. Existe uma opção escondida para inicializar em dvd ou você deve usar um usb? a inicialização segura está desativada. obrigado - vallllll


Respostas:


A primeira coisa que você deve tentar é desabilitar o Secure Boot - mas não coloque o sistema no modo CSM / BIOS / legacy. Os comentários sobre inicialização segura que você faz referência são excessivamente otimistas. Em particular, embora pareça funcionar como planejado para alguns sistemas, em outros ele enfaticamente não Trabalhar como pretendido. Se o seu não está funcionando conforme o esperado, os sintomas provavelmente seriam exatamente os que você vê. Assim, você deve primeiro tentar desabilitar o Secure Boot. Se inicializar nesse ponto, você pode deixar a Inicialização segura desabilitada ou tentar consertá-la por conta própria. Vejo minha página da Web na inicialização segura para mais sobre este assunto.

Se desabilitar o Secure Boot não ajudar, então eu recomendo que você o deixe desativado e tente o meu rEFInd gerenciador de inicialização. Você pode experimentá-lo sem alterar a configuração do disco usando a unidade flash USB ou a imagem do CD-R; ou você pode instalá-lo no Windows. (Se você fizer o último, certifique-se de instalar o driver para qualquer sistema de arquivos que você usa em sua raiz do Linux (/) ou /boot partição, embora.) Em uma configuração típica que faz não tem um separado /boot partição, uma unidade flash CD-R ou rEFInd deve ser capaz de inicializar o Linux ou o Windows diretamente e sem configuração adicional. Se você tentar o rEFInd de um disco externo e desejar usá-lo permanentemente, poderá instalá-lo a partir do Windows ou Linux.


3
2018-06-28 02:15



Desculpe eu deixei esta resposta não reconhecida por tanto tempo. Desativar o Secure Boot realmente me permite selecionar o bootloader Ubuntu UEFI no menu BIOS, o que me leva ao GRUB. Eu pareço ter um problema de driver de vídeo que não permite que o X inicie, mas isso é um problema separado. Obrigado! - ystael