Questão É possível atualizar meus drivers de placa gráfica?


Isto é o que o comando lspci -v mostra na seção do controlador compatível com VGA:

00:02.0 VGA compatible controller: Intel Corporation Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics Controller (prog-if 00 [VGA controller])
Subsystem: Dell Device 048e
Flags: bus master, fast devsel, latency 0, IRQ 44
Memory at f0200000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 18d0 [size=8]
Memory at d0000000 (32-bit, prefetchable) [size=256M]
Memory at f0000000 (32-bit, non-prefetchable) [size=1M]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915
Kernel modules: i915

O i915 é compatível apenas com o OpenGL 1.4 e não pode usar shaders e gostaria de usar algumas funcionalidades do Open GL 2.0.

É possível atualizar os drivers ou meu hardware está limitado ao OpenGL 1.4?


4
2017-10-14 14:28


origem


Você já tentou rodar o jockey-gtk? Isso procura por drivers atualizados ou "adicionais". (Apenas tentando verificar as coisas simples primeiro.) - Argusvision
Eu apenas tentei, o jockey-gtk não encontrou nada. - madmaxpt
Você também pode abrir o synaptic e pesquisar o i915. Existe um pacote xserver-xorg-intel que pode funcionar para você. Não tenho como testá-lo no meu hardware. - Argusvision
Para responder à pergunta secundária, "É possível atualizar (para usar o Open GL 2.0)? Este artigo indica sim. phoronix.com/scan.php?page=news_item&px=OTk4Mg - Argusvision


Respostas:


A Intel não possui drivers adicionais (drivers restritos) disponíveis para o Linux. Os drivers são todos de código aberto.

Se você quiser atualizar o driver para a placa de vídeo da Intel, você pode adicionar um PPA onde os drivers mais recentes são incluídos e atualizados a partir daí.

Exemplo Ubuntu X - Team

sudo apt-add-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get dist-upgrade

Se você quiser reverter (desfazer)

sudo apt-get install ppa-purge
sudo ppa-purge ppa:ubuntu-x-swat/x-updates
sudo apt-get update 
sudo apt-get dist-upgrade

4
2017-10-14 14:56



Eu fiz o que você me disse, atualizou os drivers, mas o glxinfo | O comando grep version ainda indica "string de versão do OpenGL: 1.4 Mesa 8.0.2". Alguma idéia de como dizê-lo para usar o OpenGL 2? - madmaxpt
Se a sua placa gráfica (hardware) não suporta OpenGL 2.0, então o driver não pode fazer muito (eu acho). Dê uma olhada Aqui e de acordo com o seu modelo de placa gráfica, veja se suporta OpenGL 2.0 - Nick Thom
O cartão suporta 2.0: phoronix.com/scan.php?page=news_item&px=OTk4Mg - Milan Babuškov
O link está morto. - kenorb