Questão Nenhum som proveniente de HDMI


(Ubuntu 12.04 x64)

Depois de olhar para outras perguntas (aqui e outros sites) e tentar suas respectivas respostas, ainda não consigo fazer o áudio HDMI funcionar.

Eu fiz o download dos drivers de hardware recomendados para o meu cartão (radeon hd 4350), certifiquei-me de que o cartão não estivesse mudo alsamixere defina-o como o dispositivo de saída correto nas configurações de som.

Também desativei os dispositivos de som onboard no menu da bios. Dentro aplay -l, mostra o meu cartão HDMI como hw:0,3

Mesmo depois de fazer testes de som, ainda não consigo ouvir nada. Alguma sugestão? Não tenho certeza onde ir a partir daqui, eu sou relativamente novo no Linux.


4
2017-10-28 22:38


origem


Eu encontrei uma correção: basta ativar a partir do BIOS para inicializar diretamente no monitor onde você quer que o som hdmi / displayport, ele irá ativar o som HDMI ou DisplayPort do monitor. E então você sempre pode voltar e avançar durante a reprodução para o som HDMI e laptop, a partir das configurações de som do Ubuntu. - Szabi


Respostas:


Este link resolveu meu problema:

Vá para o Dashboard em casa. Encontre propriedades de som e altere a saída de áudio para HDMI.

http://voices.canonical.com/david.henningsson/2012/04/14/audio-over-hdmi-and-displayport-in-ubuntu-12-04/

Meu áudio de saída HDMI (SPID) começou a funcionar logo após o primeiro passo do link acima, apenas instalando os drivers mais recentes da Nvidia. Afinal, a porta HDMI está na placa gráfica ;-)


4
2017-11-01 04:13



Infelizmente, a placa HDMI não aparece sob as configurações de som. Eu só posso vê-lo em pulseaudio e quando eu uso o cmd aplay -l - cypwrx


Isso me ajudou a obter áudio HDMI trabalhando no meu servidor de mídia (mesmo que seja uma placa ATI (última vez que cometi esse erro))

Confira a seção # 8:

ftp://download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html


0
2017-10-29 00:08



Obrigado pela sugestão. Infelizmente, o único dispositivo testável é hw: 0,3 (ou, eu poderia estar lendo isso errado ... forte possibilidade) Por favor, veja os resultados de aplay -l HDMI: CARD = HDMI, DEV = 0 HDMI HDA ATI, HDMI 0 HDMI Saída de áudio dmix: CARD = HDMI, DEV = 3 HDA ATI HDMI, HDMI 0 Dispositivo de mistura de amostra direta dsnoop: CARTÃO = HDMI, DEV = 3 HDA ATI HDMI, HDMI 0 Dispositivo de amostragem direta hw: CARTÃO = HDMI, DEV = 3 HDA ATI HDMI, HDMI 0 Dispositivo de hardware direto sem quaisquer conversões plughw: CARTÃO = HDMI, DEV = 3 HDA ATI HDMI, HDMI 0 Dispositivo de hardware com todas as conversões de software - cypwrx
Você pode querer editar sua pergunta para incluir as informações acima, pois é quase impossível lê-la na formatação do comentário. - Huckle
Acho que vou apenas formatar e tentar outra nova instalação. Eu tentei muitas correções (de outras sugestões) que tenho a sensação de que eu só preciso começar de novo. Obrigado pela ajuda. - cypwrx
Funciona quando você está em um ambiente ao vivo? - Huckle
Esta é uma compilação nova que está executando apenas o Ubuntu. Nada mais instalado na unidade. Eu não estou correndo via cd / usb se é isso que você está inferindo. Obrigado novamente. - cypwrx