Questão Como instalar mpeg-4 aac and h.264 decoder no Ubuntu 10.10? [fechadas]


Estou tentando reproduzir um vídeo que requer os plugins acima mencionados. Eu olhei algumas respostas sobre este tópico aqui, mas isso não resolveu o problema para mim.

O que eu tentei até agora:

  1. sudo apt-get install ubuntu-restricted-extras  ... Mas este está tendo alguns problemas e pulando o download de alguns pacotes ... então a coisa toda não é baixada completamente.

  2. eu tentei sudo add-apt-repository "deb http://archive.ubuntu.com/ubuntu $(lsb_release -sc) main universe restricted multiverse"  para adicionar os repositórios acima ao source.list do Ubuntu para os lugares de download, mas isso não ajudou.

Alguém sabe o que mais eu posso tentar fazer isso funcionar?


4
2018-01-02 08:45


origem


O Ubuntu 10.10 não é mais suportado, por favor use a última versão 12.10 ou 12.04 LTS. - Uri Herrera
Difícil de obter suporte para uma versão não suportada. - Nick Thom
@UriHerrera - Você quer dizer uma nova instalação do Ubuntu 12.10 / 12.04 LTS ou você quer dizer que eu preciso pegar os pacotes de codecs para as versões 12.x do ubuntu? Vou precisar de ajuda no último caso, como não tenho certeza onde / como baixá-los ... - user481913
Atualize seu sistema operacional e instale o ubuntu-restricted-extras pacote. - Uri Herrera
@UriHerrera Posso apenas executar a atualização para atualizar o sistema operacional ou isso precisa de uma nova instalação? - user481913


Respostas:


Você terá que baixar codecs. Para instalar o proprietário codecs digite o seguinte em uma janela de terminal.

sudo apt-get install gstreamer0.10-pitfdll gstreamer0.10-ffmpeg gstreamer0.10-plugins-bad gstreamer0.10-plugins-bad-multiverse gstreamer0.10-plugins-ugly gstreamer0.10-plugins-ugly-multiverse

Depois de ter instalado estes codecs você poderá reproduzir praticamente qualquer formato de áudio / vídeo.

Eu também recomendo que você faça o upgrade para 12.04 LTS.


4
2018-01-02 09:42



Todos eles contidos no ubuntu-restricted-extras pacote ..., você testou isso no Maverick? Isso funcionou para você no Maverick? - Uri Herrera
Sim, funcionou em Maverick .. - Mukund
@ Mukund - Eu tentei o comando para a versão de 32 bits, mas eu encontrei os seguintes erros. 1) Existem problemas e -y foi usado sem --force-yes. Então eu substitui -y com --force-yes e tentei novamente ... Desta vez há problema ao baixar certos pacotes, ou seja, não emitir. 2 2) Falha ao buscar archive.ubuntu.com/ubuntu/pool/multiverse/g/…  404 Not Found [IP: xxx.xxx.xxx.xxx 80] Tente executar o apt-get update ou --fix-missing. Então, o que vem depois? - user481913