Questão Posso usar o 12.04 para criar aplicativos do Ubuntu Phone?


Posso usar o 12.04 para criar aplicativos do Ubuntu Phone? O exemplo indica 12.10.


4
2018-02-21 04:42


origem




Respostas:


Sim.

Requisitos

o exemplo fornecido no Ubuntu App Developer lista os requisitos para:

  1. Sistema Operacional - O Ubuntu (12.04 e superior é necessário por causa dos PPAs mencionados abaixo)

  2. O Qt5 e o Ubuntu QML Toolkit estão disponíveis nos seguintes PPAs. Ambos os PPAs fornecem pacotes para Precise (12.04) e superior.

  3. Um editor de código (preferência por Criador Qt Install qtcreator - embora você possa usar o editor de sua escolha

Comandos de terminal

Executar os seguintes comandos deve instalar tudo o que você precisa:

sudo add-apt-repository ppa:canonical-qt5-edgers/qt5-proper
sudo add-apt-repository ppa:ubuntu-sdk-team/ppa
sudo apt-get update && sudo apt-get install ubuntu-sdk notepad-qml

Se você também quiser instalar o Qt Creator:

sudo apt-get install qtcreator

Observe se você já tem Qt4 ou se planeja usar isso no futuro

É bom leia a seguinte nota do PPA:

  1. Qt4 e Qt5 são totalmente co-instaláveis ​​com a migração para o novo qtchooser ferramenta. [nota: em 12.04 LTS ainda não executáveis ​​executáveis ​​de desenvolvimento Qt4 / Qt5, mas as bibliotecas estão bem]. A abordagem Debian / Ubuntu anterior dependia da renomeação de binários e do uso de alternativas. Ao empacotar no Qt5, inclua uma dependência para qt5-default além de outras dependências. Para o Qt4, use qt4-default. Instalar qt5-default também na sua máquina para ter o Qt5 como configuração padrão. Vejo man qtchooser Para maiores informações.

  2. Se você tiver pacotes Qt4 / Qt5 mais antigos com números de versão incorretos / superiores ou caso contrário, você pode usar uma variação dos seguintes para forçar as versões neste repositório, desde que os outros PPA: s estejam desabilitados:

    Você pode usar o mesmo para reverter também para as versões originais do arquivo, antes do qual você deve fazer sudo dpkg -P qt5-default qtchooser.


4
2018-02-21 08:32