Questão Como posso fazer o downgrade do AbiWord para a versão 2.8.6?


A versão do AbiWord (2.9.2) que está instalada (com Lubuntu no meu caso) tem muitos bugs! Alguém sabe se / quando o Ubuntu irá mudar isso de volta para a versão estável (2.8.6)?


4
2017-07-05 17:55


origem


Eu duvido muito que isso aconteça. Em qualquer caso, você também pode se inscrever no Lista de discussão do Lubuntu e pergunte lá.
Se você sentir vontade de consertar as coisas sozinho, confira esta discussão e a sugestão para instalar a versão que você mencionou de um ppa. Note que eu não tentei nada disso.


Respostas:


Nós tivemos o abiword 2.9 para 3 lançamentos agora, mas parece que pode ter sido adicionado por acidente. Assumindo que é o caso, o curso mais razoável de ação seria provavelmente será para oferecer 2,8 para o próximo lançamento, e oferecer um backport permitindo aos usuários instalá-lo.

Isso pode ser feito de duas maneiras:

  • oferecendo um pacote de nome diferente que fornece 2.8 mesmo quando 2.9 está disponível (por exemplo, o pacote pode ser chamado abiword-2.8 ao invés de abiword (se não for construído de uma maneira que permita que ambos sejam instalados de cada vez, suas dependências poderiam refletir isso, forçando no máximo uma das abiword e abiword-2.8 Ser instalado).

  • fazendo o downgrade da versão fornecida por abiword (em uma versão subsequente) para 2.8, mas nomeando-o com um número de versão mais alto para que ele seja instalado em um sistema que já tenha o abiword 2.9.

    A string de versão para o mais recente (e somente) abiword pacote em Raring é 2.9.2+svn20120603-8; saucy-updates tem atualmente 3.0.0~svn20130523-1ubuntu2. Pacotes de versões posteriores substituem (ou seja, por padrão, obtêm preferência por pacotes de instalação) de versões anteriores.

    Mas se um pacote fornecendo o abiword 2.8 receber uma string de versão 3.0.0+actually2.8.6, o gerenciador de pacotes a veria como uma versão posterior. (Isso pode ser fornecido em um PPA também, se alguém quiser fazer o trabalho - eu achei o AbiWord surpreendentemente difícil de compilar, pelo menos quando tento incluir todos os recursos que se poderia razoavelmente esperar que estivessem presentes. Um pacote oficial provavelmente não seria chamado porque ele não se encaixa com as convenções de nomenclatura para pacotes - versões específicas do Ubuntu como essa ubuntu em seus nomes - mas acredito que isso poderia ser realizado dentro das convenções de nomenclatura aceitas.)

Falando de um PPA, vasa1 apontou aquele existe (pelo menos) um. PPA de Lionel Le Folgoc fornece o abiword 2.8.2 (e usa um esquema de versão como o descrito acima: a string de versão é 2.9.2+svn20120213really2.8.6-0ubuntu0.1~ppa1). No entanto, esse PPA infelizmente fornece apenas o abiword 2.8.2 para Precise. (Se você selecionar uma versão diferente no menu suspenso "publicado em" nessa página, ela não aparecerá.)

Com tudo isso dito, um pacote Ubuntu desclassificado para o abiword provavelmente não ser oferecido oficialmente. Isto é porque:

  • A versão de desenvolvimento do abiword fica melhor e melhor (no geral e em termos de estabilidade) a cada lançamento. A maioria ou todos os erros que você experimentou provavelmente foram corrigidos em uma versão posterior de desenvolvimento. É por isso que é bobagem incluir uma versão de desenvolvimento congelada em uma versão estável do Ubuntu - ela terá muitos bugs que nunca serão corrigidos a menos que SRU processo é realizado. Esse processo não aconteceu para o abiword nos últimos lançamentos do Ubuntu. Mas isso também significa que oferecer a próxima versão de desenvolvimento corrigirá a maioria dos bugs.

  • Eu não tenho certeza se o AbiWord 3 terá um release estável (isto é, um lançamento estável do próprio projeto AbiWord, que pode ser empacotado para inclusão downstream em sistemas operacionais como Debian, Ubuntu e outros sistemas GNU / Linux). Mas parece provável que um lançamento - ou pelo menos um beta - esteja disponível. Espero que seja lançado a tempo de entrar em Saucy. A mudança do número da versão de 2.9 ... para 3.0 ... significa que uma versão está chegando em breve.

  • GTK + 2.0 é ainda embalado para as versões mais recentes do Ubuntu, mas há um empurrão para portar aplicativos para o GTK + 3.0, já que isso pode fornecer uma melhor integração com os ambientes de desktop de hoje, e porque eventualmente o GTK + 2.0 pode ser descontinuada para remoção.

Eu tentei dar uma resposta razoável que incorpora relevante   factos ("bom subjetivo"). Isto é CW então é mais fácil para   Alguém para atualizar / melhorar. Com isso dito, se você quer começar ou   participar em uma discussão completa deste tópico, em algum lugar   gostar Fóruns do Ubuntu seria melhor.


4