Questão LTS Enablement Stacks - Devo usar quantal, raring ou saucy?


Eu instalei o Kubuntu 12.04 de um beta ISO e eu tenho atualizado desde então. No entanto, desejo ativar a pilha de ativação de hardware do Precise agora.

Eu tenho duas perguntas:

Primeiro, como decido entre as versões? Por exemplo, entre quantal, raring ou saucy, eu simplesmente escolheria o mais recente? (E é picante disponível para este propósito ainda?)

sudo apt-get install linux-generic-lts-raring xserver-xorg-lts-raring 

ou

sudo apt-get install linux-generic-lts-saucy xserver-xorg-lts-saucy

Em segundo lugar, se eu optar pela pilha de ativação de hardware usando a versão de lançamento, haverá alguma dificuldade ou desafio em mudar para as versões posteriores ou subsequentes? E o que eu teria que fazer na época?


4
2017-09-03 14:09


origem


@ Braiam-eu instalei o 12.04 há muito tempo! ;-) - MountainX


Respostas:


A escolha entre quantal, raring e saucy depende de você, mas esses stacks são nomeados após o lançamento em que aparecem. Assim, o stack picante não é lançado e deve ser considerado inadequado para a produção.

Movendo entre pilhas é possível. Eles são apenas pacotes, afinal.

O único cenário realmente ruim está começando em 12.04, instalando o HWE do 13.04 e atualizando a distribuição para 12.10. Sua pilha X seria mais nova que o resto do sistema em uma configuração não testada. Eu recomendaria remover os pacotes da pilha HWE antes de atualizar.

O upgrade padrão do LTS (por exemplo, para 14.04) é bom, embora você possa precisar atualizar manualmente o HWE. Também devo salientar que, em 14.04, as duas únicas pilhas suportadas para 12.04 são a pilha original e a 14.04 (que continuará a ser suportada durante os restantes 3 anos de vida útil de 12.04).


4
2017-09-03 14:33



então eu poderia instalar a pilha HWE para raring agora e quando saucy é lançado eu faria apt-get remove linux-generic-lts-raring xserver-xorg-lts-raring e apt-get install linux-generic-lts-saucy xserver-xorg-lts-saucy. Corrigir? - MountainX
também, quando o 14.04 sair, planejo fazer o upgrade de 12.04 para 14.04. Eu suponho que, se eu tiver uma pilha HWE instalada, precisaria removê-la para fazer a atualização para o 14.04. Corrigir? - MountainX
1) Se você quisesse atualizar para a pilha HWE picante, sim. 2) Eu honestamente não tenho certeza qual será a situação para grandes atualizações. Eu suponho que eles serão automaticamente removidos pelo instalador, mas mesmo que não sejam, eles serão ultrapassados ​​pelas versões do 14.04, portanto, não devem causar conflito. Custa muito pouco tempo para removê-los antes de fazer as coisas, o que pode ser um método mais seguro. - Oli♦