Questão Como compatível com versões anteriores o Ubuntu SDK?


Primeiro, deixe-me dizer: pelo SDK, não estou me referindo ao QT Creator, mas às bibliotecas QML do Ubuntu, na verdade estou usando o Geany para toda a minha programação.

Quando o Ubuntu lançou o Ubuntu SDK pela primeira vez eu troquei um aplicativo que eu estava trabalhando para QML, estou usando o QML para a GUI e C para todos os trabalhos internos. Depois de atualizar para o 13.10 meu aplicativo praticamente quebrou, não foi difícil para mim descobrir o que tinha mudado com o SDK do Ubuntu e fazer as mudanças apropriadas, mas agora estou preocupado com o SDK em geral, eles só fizeram um dramatismo muda porque ainda está funcionando, ou todas as versões do Ubuntu vão quebrar a compatibilidade com aplicativos? Em outras palavras, uma vez que eles tenham o Ubuntu SDK lançado oficialmente, ele será o mesmo, independente da versão do Ubuntu que as pessoas têm?

E há alguma palavra sobre quando a versão final do Ubuntu SDK será lançada?


4
2017-10-30 01:46


origem




Respostas:


O SDK era bastante fluido, já que este era o desenvolvimento inicial e nós só alcançamos nosso primeiro estado "estável" com o lançamento do Ubuntu 13.10. Não deve haver nenhuma quebra na API a partir de agora sem antes passar para um período de reprovação. Se isso for uma preocupação para um número suficiente de pessoas, poderemos realizar uma sessão na próxima UDS para discutir como lidar com isso.


4
2017-10-30 02:17



Incrível, obrigado pela resposta. Eu pensei que era o caso, eu estava um pouco preocupado desde que eu tenho colocado muito trabalho no meu aplicativo. - KoRnKloWn