Questão Destaques param de funcionar de repente em LibreOffice


Eu posso escrever caracteres como á, é, ó, ã, ê, etc muito bem no Kubuntu 14.04.

Mesmo no LibreOffice.

No entanto, se eu alternar as janelas do LibreOffice para, digamos, o Chrome ou mesmo o Dolphin, e depois voltar para o LibreOffice, esses caracteres não serão mais registrados e, em vez disso, serão escritos sem sotaque. .

Isso é muito chato e eu tenho trabalhado com o KDE System Settings nas últimas horas sem sucesso. Eu realmente gostaria de ajuda.

Desde já, obrigado,


4
2018-04-21 05:54


origem


Você provavelmente encontrará a resposta / solução aqui: askubuntu.com/questions/367745/keyboard-language-self-switches; a causa é (eu acho) a mesma. A resposta do nux é provavelmente o que você precisa fazer. - Jacob Vlijm


Respostas:


Eu tive exatamente o mesmo problema. Eu também noto que este problema é relacionado ao KDE e ao IBUS. A solução acima não funcionou de todo. Parece que outros problemas semelhantes podem estar relacionados a esta combinação de pacotes (KDE, ibus, libreoffice-kde). Eu resolvi isso no meu sistema, removendo libreoffice-kde e mantendo libreoffice-gnome.

Links que podem ajudar:

  1. O mesmo problema, no Fedora 16, e a solução no comentário n. 5: https://bugzilla.redhat.com/show_bug.cgi?id=825067

  2. O mesmo, no openSUSE: http://forums.opensuse.org/showthread.php/473607-Ibus-don-t-work-in-Libreoffice-%28Opensuse-12-1%29


3
2018-05-24 17:59





O que me ajudou foi remover o pacote libreoffice-kde.

Eu também desinstalei todos os idiomas ingleses no KDE e Unity e deixei apenas um (meu, checo).

Agora parece OK, então acho que a remoção do pacote libreoffice-kde foi uma maneira de ajudar com isso.


1
2018-06-03 12:11





Jacob Vlijm me deu este link muito útil:

Auto-interruptores de linguagem de teclado

Minha solução foi a dada pela Adobe. Eu matei ibus e tudo funcionou; Tendo encontrado o culpado, abri de novo e passei por suas preferências para resolver o problema.


0
2018-04-21 18:19



Tudo funcionou até eu começar a ter problemas com cromada. Então agora com o ibus, o Libreoffice está quebrado; sem o ibus, o Chrome está quebrado. Vou experimentar a opção de Luan Carvalho acima e ver se funciona! - Peterson Silva


Eu tive o mesmo problema e eu desinstalar o libreoffice-kde e funciona

sudo apt-get autoremove libreoffice-kde

0
2017-08-13 04:38





Edição /etc/default/locale e reiniciar depois resolve também; essa situação acontece quando há vários idiomas definidos em "locale". um que funciona está se pondo LANG="en_US.UTF-8" e todos os outros pt_PT.UTF-8 com um LibreOffice em Inglês e Português para o resto. Ou apenas mudando LANGUAGE.


0
2017-10-13 09:43