Questão MySql Workbench no Ubuntu 14


Oi eu acabei de instalar a mais nova versão do Ubuntu, 14e agora preciso instalar o MySql Workbench.

Eu faço o download do pacote .deb do site mysql mas quando tento instalá-lo eu obtenho este erro:

Preparing to unpack .../mysql-workbench-community-6.1.4-1ubu1310-amd64.deb ...
Unpacking mysql-workbench-community (6.1.4-1ubu1310) ...
dpkg:dependency problems prevent configuration of mysql-workbench-community:
 mysql-workbench-community depends to mysql-client; however:
  The mysql-client package didn't install.

dpkg: error processing package mysql-workbench-community (--install):
 dependency problems - leaving unconfigured
Processing triggers for gnome-menus (3.10.1-0ubuntu2) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu1) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.54ubuntu1) ...
Processing triggers for shared-mime-info (1.2-0ubuntu3) ...
Processing triggers for hicolor-icon-theme (0.13-1) ...
Errors were encountered while processing:
 mysql-workbench-community

Eu tento correr sudo apt-get -f install e sudo apt-get update, Eu tento instalar manualmente dependecies mas não funcionou.

Pode me ajudar?

Obrigado

EDITAR:

I ran: `dpkg --get-selections | grep mysql`

e eu entendo isso:

libdbd-mysql-perl               install
libmysqlclient18:amd64              install
mysql-client-5.6                install
mysql-client-core-5.6               install
mysql-common                    install
mysql-common-5.6                install
mysql-server-5.6                install
mysql-server-core-5.6               install
mysql-workbench-community           deinstall

4
2018-04-27 09:27


origem


Você precisa instalar o mysql-client antes. sudo apt-get install mysql-client - Hamed Kamrava
Sim, eu instalei antes - Teo
Mas o seu log de erro diz The mysql-client package didn't install. Verifique se este pacote foi instalado com sucesso. - Hamed Kamrava
Eu corro isso agora: sudo apt-get install mysql-client-5.6 mas eu obtenho: mysql-client-5.6 já é a versão mais nova. - Teo


Respostas:


Eu resolvi assim:

1) desinstalar o servidor mysql

2) deletar todas as configurações do mysql-workbench

3) ao invés de usar .tar.gz no site mysql, eu instalo tudo pelo Software Center.

Agora funciona ..


4
2018-04-27 11:04



além de / usr / share / mysql-workbench, onde mais eu poderia encontrar arquivos de configuração? Ainda não é possível instalar o ambiente de trabalho com o mysql 5.6 instalado. - Dylan Pierce
Execute um comando como: sudo find / -name mysql-workbench - Teo