Questão dell 5537 Touchpad não funciona (Ubuntu 14.04)


Depois de atualizar meu novo Ubuntu de 12.04 para 14.04, descobri que o touchpad não está funcionando. O mais estranho é que parece ser detectado, como:

cat /proc/bus/input/devices

I: Bus=0011 Vendor=0002 Product=0007 Version=01b1
N: Name="SynPS/2 Synaptics TouchPad"
P: Phys=isa0060/serio1/input0
S: Sysfs=/devices/platform/i8042/serio1/input/input5
U: Uniq=
H: Handlers=mouse1 event5 
B: PROP=1
B: EV=b
B: KEY=e520 30000 0 0 0 0
B: ABS=660800011000003

e também

xinput

⎡ Virtual core pointer                        id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                  id=4    [slave  pointer  (2)]
⎜   ↳ USB Multi-Smart Mouse                       id=9    [slave  pointer  (2)]
⎜   ↳ SynPS/2 Synaptics TouchPad                  id=12    [slave  pointer  (2)]
⎣ Virtual core keyboard                       id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard                 id=5    [slave  keyboard (3)]
    ↳ Power Button                                id=6    [slave  keyboard (3)]
    ↳ Video Bus                                   id=7    [slave  keyboard (3)]
    ↳ Power Button                                id=8    [slave  keyboard (3)]
    ↳ Laptop_Integrated_Webcam_HD                 id=10    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard                id=11    [slave  keyboard (3)]
    ↳ Dell WMI hotkeys                            id=13    [slave  keyboard (3)]

também detalhes do touchpad no xinput parecem bem:

xinput --watch-props 12

Device 'SynPS/2 Synaptics TouchPad':
    Device Enabled (134):    1
    Coordinate Transformation Matrix (136):    1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
    Device Accel Profile (263):    0
    Device Accel Constant Deceleration (264):    1.000000
    Device Accel Adaptive Deceleration (265):    1.000000
    Device Accel Velocity Scaling (266):    10.000000
    Device Product ID (253):    2, 7
    Device Node (254):    "/dev/input/event5"
    Evdev Axis Inversion (267):    0, 0
    Evdev Axis Calibration (268):    <no items>
    Evdev Axes Swap (269):    0
    Axis Labels (270):    "Abs MT Position X" (288), "Abs MT Position Y" (289), "Abs MT Pressure" (290), "Abs Tool Width" (287), "None" (0), "None" (0), "None" (0)
    Button Labels (271):    "Button Left" (137), "Button Unknown" (256), "Button Right" (139), "Button Wheel Up" (140), "Button Wheel Down" (141)
    Evdev Middle Button Emulation (272):    0
    Evdev Middle Button Timeout (273):    50
    Evdev Third Button Emulation (274):    0
    Evdev Third Button Emulation Timeout (275):    1000
    Evdev Third Button Emulation Button (276):    3
    Evdev Third Button Emulation Threshold (277):    20
    Evdev Wheel Emulation (278):    0
    Evdev Wheel Emulation Axes (279):    0, 0, 4, 5
    Evdev Wheel Emulation Inertia (280):    10
    Evdev Wheel Emulation Timeout (281):    200
    Evdev Wheel Emulation Button (282):    4
    Evdev Drag Lock Buttons (283):    0

Vale a pena mencionar que o mouse externo funciona corretamente. Além disso, na janela "Configurações> Mouse e touchpad" não há configurações para o touchpad, apenas a velocidade da regulação de duplo clique.

Eu seria grato por alguma ajuda


4
2018-06-14 14:15


origem




Respostas:


encontrei a solução sozinho. isso foi útil. Acontece que o psmouse perdeu algumas opções no carregamento. Além disso, descobri que pacotes xserver-xorg-input-synaptics e gpointing-device-settings estavam desaparecidas. Eu instalei eles

sudo apt-get install xserver-xorg-input-synaptics gpointing-device-settings

agora posso configurar meu touchpad a partir da GUI.

tudo funciona agora então por favor, marque isso como resolvido


4
2018-06-15 01:23