Questão Bloqueios de teclado no IntelliJ IDEA no Ubuntu 14.04


Você poderia me ajudar com uma questão estranha? Eu uso Intellij IDEA 13 no Ubuntu 14.04, e de vez em quando meu teclado completamente (sim, completamente, não é sobre atalhos) bloqueia no IDEA. Eu ainda posso fazer o que quiser no IDEA com meu mouse, também posso usar o teclado em qualquer outro lugar, exceto o IDEA. E isso só pode ser corrigido reiniciando o IDEA até o momento.

Alguém pode dar uma dica, por favor?


165
2017-07-24 06:58


origem


Pode ser que o seu teclado esteja simplesmente sendo capturado por algum campo dentro do IntelliJ? É algo aleatório ou algo específico o aciona? - Ruraj
Eu não acho que algum campo pode capturar o teclado assim, mas vou verificá-lo mais precisamente na próxima vez. E parece ser algo aleatório. - Treble Snake
Meu colega e eu estamos experimentando exatamente a mesma coisa (mesmo sistema operacional e IntelliJ 13.1.4). Eu tenho que reiniciar o IntelliJ uma vez a cada poucas horas (eu sou capaz de usar Alt-F4, no entanto) - extremamente irritante. Eu também acho que isso aconteça completamente aleatoriamente. A última vez que estive no meio da edição de um arquivo HTML. Não enquanto pressiona um atalho. - Halle Knast
Eu tive duas instâncias do IntelliJ rodando e as duas ficaram congeladas. Não sei se é relevante, mas quando fecho o IDE, a desanexação de um servidor de aplicativos em execução normalmente leva muito pouco tempo. Depois que um congelamento acontece, eu tenho que cancelar isso porque não parece terminar. - Halle Knast
Esse é um problema Java que afeta outras GUIs do Java Swing, incluindo a interface do usuário SOAP. "ibus-daemon -rd" corrige o problema também - rjdkolb


Respostas:


Existe um uma questão em aberto no jetbrains youtrack para intellij ideia que recomendam duas soluções:

  1. A entrada do teclado pode ser desbloqueada reiniciando o daemon do IBus em um console:

    ibus-daemon -rd
    
  2. O IBus pode ser desativado para o IDEA, desativando o env. XMODIFICADORES variáveis, mas a capacidade de inserir caracteres nacionais no IDEA será perdida:

    XMODIFIERS="" idea.sh
    

Eu usei o segundo e resolvi meu problema.


206
2017-10-18 16:50



> "ibus-daemon -rd" de um console. Isso funcionou! Muito obrigado!) - Treble Snake
6 meses depois, a Opção 1 não é mais recomendada, pois pode causar falha na JVM: / - mike
O que quer dizer com personagens nacionais, @Mike, funcionou para mim hoje, dia 2 de junho - Abderrahmane TAHRI JOUTI
"ibus-daemon -rd" - Estou pensando seriamente em tatuar isso no meu braço. - Balázs Mária Németh
Última atualização sobre o assunto (17 jun 2015) recomenda export IBUS_ENABLE_SYNC_MODE=1 - Nacho Coloma


Consegui resolvê-lo com o que encontrei Aqui isso é basicamente adicionar export XMODIFIERS="" em idea.sh


14
2018-03-05 16:45



parece funcionar aqui! - Marc Hauptmann


Para solução permanente, a  01 de outubro de 2015 atualização sobre o assunto recomenda:

Atualize o IBus para a versão 1.5.11 ou adicione export IBUS_ENABLE_SYNC_MODE=1 para o seu ~/.profilee reinicie uma sessão.

Alternativamente, você pode desligar o IBus em System Settings | Language Support | Keyboard input method.

O IDEA 15 mostrará um aviso se uma versão incompatível do IBus estiver em uso.


5
2017-11-30 11:53





Eu tentei isso e está funcionando até agora, mas atualizarei se congelar novamente. Eu vi uma sugestão no youtrack que sugere desligar o iBus que parece interferir particularmente por causa do uso do atalho ctrl + space para alterar as configurações de idioma. Você pode fazer isso indo para:

suporte a idiomas> sistema de método de entrada de teclado> nenhum

enter image description here

**** ATUALIZAÇÃO *****

Depois de executá-lo por um tempo, essa técnica ainda não funcionou, enquanto eu continuava congelando. Eu acho que por enquanto eu vou ficar com a seguinte solução para reiniciar o ibus que é um pouco inconveniente, mas o que você pode fazer.

entrar no terminal

tipo:

ibus-daemon -rd

1
2018-04-05 00:33



obrigado, ibus-daemon -rd é o que eu estava procurando. - Lambart