Questão 15.10 só vai começar com `nomodeset`


Não tenho certeza do que começou o problema; Eu não acho que nem fiz uma apt-get update, mas agora não consigo iniciar meu laptop sem adicionar nomodeset para a linha de comando do GRUB.

Indo sem ele produz uma tela preta, ou um aviso de "modo de baixa gráfica". Tentar consertar o problema ou cancelar o aviso parece me bloquear (não consigo nem chegar a um terminal virtual).

Meu sistema é um Thinkpad T420, com gráficos Optimus Nvidia + Intel.

Atualmente executando com nvidia-352 e bumblebee, e tentei atualizar para os drivers Intel Oibaf, mas eu ainda estou preso.


5
2017-11-01 14:39


origem


Eu acredito que você precisaria remover os drivers nvidia antes de usar o repositório Oibaf - Charles Green


Respostas:


Para resolver o seu problema, instale os últimos drivers NVIDIA estáveis ​​355.

Mas primeiro desinstale todos os softwares relacionados à NVIDIA que você já instalou antes.

Isso inclui remover os pacotes de abelha, eles serão substituídos por nvidia-prime.

Abra um terminal e execute:

sudo apt-get purge nvidia* bumblebee  
sudo reboot

Em seguida, (re) instale os drivers NVIDIA:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-355 nvidia-prime
sudo reboot  

Alterne entre gráficos Intel e nvidia usando Configurações do NVIDIA X Server -> Perfis principais.

Nota: Caso você tenha usado quaisquer drivers de GPU relacionados a PPAs - purgue-os antes de instalar também !


2
2017-11-01 15:42



Obrigado, isso funciona. O mais estranho é que eu tive Bumblebee trabalhando ontem; Eu ainda me pergunto o que deu errado. - SlightlyCuban
Pode ter que aceitar a resposta aceita. Atualizado para 4.2.0-19 e o nvidia-prime começou a mostrar comportamento semelhante. Não posso usar meu cartão nvidia agora, mas ele também está sempre ligado, matando minha bateria. - SlightlyCuban
@SlightlyCuban: Talvez algo deu errado quando o novo kernel 4.2.0-19 foi instalado. Tudo estava funcionando antes, então está provado que as instruções de instalação estão corretas. Agora você tem 3 opções: 1.) Inicialize o sistema com o kernel antigo e espere que a próxima versão do kernel seja liberada ou purgada e reinstale o kernel atual. 2.) Desinstale e reinstale os drivers NVIDIA 355. 3.) Purgue os drivers NVIDIA 355 e instale os novos drivers oficiais NVIDIA 358, que trazem muitas correções de bugs e melhorias. :) - cl-netbox
correção: foi nvidia-358 que parece ser a causa do problema. Ou ele sempre inicializa com o cartão discreto ou apenas inicializa em gráficos baixos. 4.2.0-19 + nvidia-355 parece estar "de volta ao normal". - SlightlyCuban