Questão Irritante cintilando em 16.04 LTS - Chrome


Eu atualizei de 4.4.0 para 4.4.8 e 4.5.2 no Ubuntu 16.04 LTS de 64 bits, e ainda está acontecendo.

No 4.5.2 é ainda mais frequente e principalmente no Chrome (ainda não experimentou o firefox ou o opera). Toda vez que eu abro uma nova página da web. Qualquer maneira de consertar isso, ou é um bug?

00:02.0 VGA compatible controller: Intel Corporation HD Graphics 5500 (rev 09)
04:00.0 Display controller: Advanced Micro Devices, Inc. [AMD/ATI] Venus XTX [Radeon HD 8890M / R9 M275X/M375X] (rev 81)

Felicidades.


197
2018-05-03 06:31


origem


A mesma coisa que experimentei no Ubuntu 14.04.4 - Billal Begueradj
Eu também estou enfrentando o mesmo problema, especialmente ao usar o facebook. Isso é muito chato. - sgiri
Experimentar --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers   algumas informações extras aqui: productforums.google.com/forum/#!topic/chrome/… - Postadelmaga
Googler aqui. Este bug está sendo rastreado no rastreador de problemas do Chromium em # 606152 - Flickering na Intel com uploads de uma cópia. - Dan Dascalescu
Eu mudei para a pilha HWE (kernel 4.8 e X-7.7). Parou o flickring. Há algum problema com i915 (Driver de gráficos Intel HD) no kernel 4.4 series. - Manoj Sawai


Respostas:


Depois de alguma pesquisa, encontrei uma solução para esse problema. Está trabalhando para mim agora.

Desativei a aceleração de hardware do meu navegador de

Settings > Advance Settings > System > uncheck the hardware acceleration

Espero que isso funcione na sua máquina.


estou usando google-chrome-stable Version 50.0.2661.94 (64-bit) em Ubuntu 16.04

-----EDITAR----

Se você encontrar lag deslocado e rasgo na tela. Faça como sugerido por Amos Folarin no comentário abaixo:

Vamos para: chrome://flags/#smooth-scrolling e habilite-o.


186
2018-05-05 17:54



Eu tentei isso, corrige o problema, mas faz o meu atraso de rolagem e rasgo na tela. - Mookey
Isso realmente não deveria ser aceito, já que não é uma solução, é definitivamente uma solução. - theV0ID
Isso não tem efeito sobre o piscar para mim. - DavidJ
Esta solução funcionou para o meu XPS13 9343, a cintilação definitivamente parou ou não é perceptível. Eu também tentei a outra solução sugerida aqui configurando chrome: // flags / # enable-gpu-rasterization para 'Force-enabled para todas as camadas' mas isso não funcionou, apenas a desativação da aceleração de hardware no chrome pareceu funcionar. Mas concorde com @ theV0ID que a sua não é ideia. - Amos Folarin
Tente também ativar chrome: // flags / # smooth-scrolling para rolagem suave. Estou usando o XPS13 + Ubuntu16.04 funciona bem com a opção de aceleração de hardware desmarcada - Amos Folarin


Eu tive o mesmo problema, definindo rasterização GPU para 'força-habilitado para todas as camadas' parece estar finalmente trabalhando:

Chrome Flags: GPU rasterization


158
2017-08-08 07:52



link rápido: chrome: // flags / # enable-gpu-rasterization - JohannesNE
trabalhou para mim também. - Sufiyan Ghori
Parou de funcionar, o tremeluzir voltou, acho que depois de atualizar para o Chrome versão 53.0.2785.92 (64 bits) - Omid
Isso reduz drasticamente a oscilação, mas ainda existe na Caixa de entrada do Google, por exemplo (atualmente, o único lugar onde vejo isso). - TiGR
Funciona, mas agora apenas o canto superior esquerdo de algumas imagens está sendo exibido. O que para mim foi chrome: // flags / # ignore-gpu-blacklist - Jasny - Arnold Daniels


Abra um terminal e insira este comando:

sudo nano /usr/share/applications/chromium-browser.desktop

e role para baixo até chegar a esta linha:

Exec= chromium-browser

Em seguida, adicione esses dois parâmetros

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

Pressione Ctrl + O para salvar e Ctrl + X para sair.

Em seguida, insira este comando:

sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf

e adicione estas linhas

Section "Device"
   Identifier  "Intel Graphics"
   Driver      "intel"
   Option      "AccelMethod"  "sna"
   Option      "TearFree"    "true"
   Option      "DRI"    "3"
EndSection

Pressione Ctrl + O e depois Ctrl + X.

Abra o Chromium e escreva para a barra de endereços: chrome://flags/ e entre.

  • Ativar-zero-cópia
  • Ativar substituir lista de renderização de software
  • Ativar tela de lista de exibição 2D

Por fim, abra as configurações do Chrome e clique em:

  • Use aceleração de hardware quando disponível

38
2017-07-27 08:10



Trabalhei na minha CPU Dell XPS 15 95050 Intel® Core i7-6700HQ a 2,60GHz Intel® HD Graphics 530 (Skylake GT2). - Prydie
No meu caso (depois de tentar várias soluções) eu simplesmente habilitei aquelas bandeiras que você mencionou (zero-copy, Override Software Rendering List, Display 2D List Canvas) e parece ter corrigido (na Intel HD Graphics). - Nahuel
As duas opções de linha de comando (desabilitar soluções alternativas / habilitar buffers de memória gpu nativos) parecem não funcionar mais, mas criar 20-intel.conf arquivo funcionou para mim! Também habilitado rasterização gpu (não tenho certeza se é importante). - terabaud
A única solução trabalhada para mim. obrigado - Darkside
Apenas adicionando 20-intel.conf trabalhou para mim - não tinha que fazer mais nada. - Vadi


Eu consertei da seguinte forma:

sudo apt-get purge xserver-xorg-video-intel

depois reinicie. Isso ocorre porque os drivers da Intel mudaram para modesetting. Para mais informações veja este comentário no tópico do bug do Chromium.


37
2017-08-19 14:25



Eu fui a rota flags chrome e, em seguida, fui esta rota em vez disso, redefinir as bandeiras para o padrão e limpou o material intel. Por enquanto, tudo bem. - Sethen
obrigado. Eu tenho um Intel NUC que tem alguns anos e passou por algumas atualizações. É em 16.04.2 mas sua sugestão encontrou pacotes para limpar. Ele não pisca mais (meu vídeo HDMI estava piscando e ligando cerca de 1 ou 2 Hz depois de algumas atualizações recentes; achei que ele havia desenvolvido uma falha de hardware após 8 anos de serviço). - Tim Richardson
Esta resposta deve ser muito maior! - Galgalesh
É isso? Ele funciona sem falhas !!! Resposta totalmente subestimada. Muito obrigado, companheiro! - uloco
Obrigado! Isso resolveu o problema para mim. Sua resposta deve ser alguns pontos mais alta do que é. - Anthony D.


Nenhuma dessas respostas pareceu me ajudar. O que acabei fazendo que parece tê-lo consertado (minha referência foi este site http://www.bang-olufsen.com/ que cintilou como CRAZY e agora funciona suavemente) é isso:

1.- Navegado para chrome://gpu/. Isto é o que mostrou:

enter image description here

2.- Eu tentei corrigir os problemas um por um. No meu caso, ativar esses sinalizadores corrigiu alguns deles: GPU rasterization, Override software rendering list. Então ficou assim:

enter image description here

3.- Eu editei o lançador de desktop e adicionei os parâmetros --disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers.

4.- Depois disso, nenhum problema mais detectado, tudo mostra como "acelerado por hardware" e, mais importante, sem mais oscilações:

enter image description here

Se você adicionar os parâmetros ao lançador primeiro, a lista de problemas deverá ser mais curta e provavelmente será mais fácil descobrir quais sinalizadores irão ajudá-lo com os problemas que você deixou.


25
2017-09-14 12:29



Esta é uma boa referência. Eu usei-o para resolver o meu problema com o firefox, onde foi simplesmente resolvido desmarcando a caixa "Usar aceleração de hardware" nas configurações avançadas. - Bach
Isso reduziu o tremeluzir para mim, mas ainda acontece com frequência ... - addison


Com o Chrome versão 51.0.2704.103 (64 bits) as bandeiras

--disable-gpu-driver-bug-workarounds --enable-native-gpu-memory-buffers

não funciona mais.

A melhor maneira que podemos fazer é voltar para o Chrome 50 (versão 50.0.2661.86 (64 bits)), aqui está uma instrução de como você pode voltar atrás: como faço o downgrade do google chrome? 

É importante que pressionemos o Google a corrigir esse problema, vote no bug no Chromium e na página do produto do Google:

https://bugs.chromium.org/p/chromium/issues/detail?id=606152

https://productforums.google.com/forum/#!topic/chrome/CtKF2BiskT8;context-place=forum/chrome


7
2018-06-19 08:02



Nao funciona para mim. - ComBin
@ComBin: você tentou voltar para a v50 e usou as bandeiras? No entanto, siga o link para o bug do cromo, existem várias propostas de solução diferentes para fazer isso funcionar nas versões atuais do chrome / -ium. - user157697
Eu não quero v50, obrigado. Eu encontrei a melhor maneira de consertar isso, veja minha resposta abaixo. - ComBin
AHa, no bug cromo, os caras disseram que isso teria problemas enormes de desempenho. No entanto vou tentar algumas sugestões dos erros de cromo quando eu tenho o tempo, tanto quanto eu entendi que o cromo é apenas o sintoma não a causa. Vou mantê-lo atualizado se eu encontrar algo melhor / outro. Felicidades. - user157697


chrome://flags/ > GPU rasterization > Enable,

Isso finalmente funcionou para mim! Encontrou-o no final deste Formulário Google! https://productforums.google.com/forum/#!msg/chrome/CtKF2BiskT8/dLXKfU2XAQAJ


5
2017-10-16 20:44