Questão Como posso desativar o Bluetooth na inicialização do sistema?


Como posso desativar o Bluetooth na inicialização do sistema?


277
2017-10-16 21:02


origem


Eu não acho que "deve ser a configuração padrão natural", as pessoas são obrigadas a querer usar o Bluetooth em seus computadores sem ter que ligá-lo (você não parece ter um mouse ou teclado Bluetooth, se esses eram seus dispositivos de entrada primários que você gostaria que o Bluetooth ligasse a partir da inicialização). No entanto, eu concordo que uma maneira de escolher como você deseja que o Bluetooth esteja na inicialização seria útil. - roadmr
O normal e natural é deixar você escolher, nas configurações do bluetooth, se você quer que ele seja ligado ou desligado quando for inicializado. Não é natural que as pessoas o desliguem ou liguem sempre que ligarem o computador. Estamos falando de tornar o Linux o melhor sistema de desktop, não o pior, não é mesmo? - Robert
Concordamos que deixar as pessoas escolher é a melhor opção. Veja aqui algumas maneiras possíveis de fazer isso. answers.launchpad.net/ubuntu/+source/bluez/+question/51440 - roadmr
Isto é bug # 1073669. - colan
É inacreditável que, na 14ª edição, ainda estamos "ensinando" aos desenvolvedores do Ubuntu coisas como "a opção de ter bluetooth ligado ou desligado na inicialização deve estar disponível para usuários normais, e não apenas para aqueles que gostam de pesquisar em linhas intermináveis de fóruns públicos ". - Rodrigo


Respostas:


18.04+ usuários que não têm naturalmente um /etc/rc.local, você precisará criar um e torná-lo executável. Para facilitar as coisas, basta colar o seguinte comando em um terminal:

sudo install -b -m 755 /dev/stdin /etc/rc.local << EOF
#!/bin/sh
rfkill block bluetooth
exit 0
EOF

Corre sudoedit /etc/rc.local e adicione isso antes da linha com exit 0:

rfkill block bluetooth

Você ainda deve ser capaz de ativar o Bluetooth através do miniaplicativo da barra superior.

este devemos funciona para a maioria dos sistemas, mas parece que há alguns bugs ocultos na ACPI do kernel para Thinkpads. Se você está em um Thinkpad, adicione o seguinte para /etc/rc.local:

echo disable > /proc/acpi/ibm/bluetooth

Ou confira ibm-acpi - Driver IBM ThinkPad ACPI Extras - alguns relatórios sugerem que o ibm-acpi inclui controle bluetooth (entre outras coisas legais). Mas eu não tenho o hardware, então estou completamente impossibilitado de verificar essas afirmações. Boa sorte.


189
2017-08-18 09:00



Para Thinkpads (e apenas Thinkpads) isso funciona: echo disable > /proc/acpi/ibm/bluetooth em /etc/rc.local - Marius Gedminas
rfkill block bluetooth trabalhei para o Thinkpad T430u - bmaupin
Nenhum funcionou para mim (ThinkPad x201) quando eu coloquei um de cada vez em /etc/rc.local. o rfkill block bluetooth comando funciona, mas não na inicialização. O sinalizador -x está definido em /etc/rc.local. Estou executando o Xubuntu 13.10. - Kyle Falconer
No Ubuntu 15.10 com systemd você precisa de um pouco mais para reabilitar o uso do etc/rc.local Arquivo: askubuntu.com/a/696226/34298 - rubo77
Se o nosso rc.local é apenas um arquivo vazio, onde devemos adicionar 'rfkill block bluetooth'? - Sss


Eu encontrei um how-to com uma "solução alternativa" limpa Aqui (link de arquivo para a posteridade)

Realmente mudando /etc/bluetooth/main.conf foi o suficiente para mim.

Do artigo:

Procure a entrada:

InitiallyPowered = true

e altere o valor para:

InitiallyPowered = false

Foi o suficiente para mim, embora o artigo descreva alguns outros passos que podem ou não ser necessários.

Em Ubuntu 17.10 e Ubuntu 18.04 a opção InitiallyPowered foi substituído por AutoEnable


71
2018-06-25 18:00



não funciona para laptop 530u3b samsung, bluetooth está sempre ligado após a reinicialização e acorde - Maxim Kim
Isso só funcionaria se eu também usasse a resposta de Saeed Zarinfam /etc/init.d/bluetooth stop em rc.local. Parece que quando o serviço é iniciado, ele também traz a energia para o bluetooth. Eu precisava de ambos para fazer isso funcionar. (ThinkPad x201, Xubuntu 13.10) - Kyle Falconer
Não funcionou para mim no thinkpad t420 - UpTheCreek
"Procurar a entrada" é precisamente inútil para aqueles de nós cuja main.conf não contém este parâmetro ou qualquer comentário indicando sua localização padrão. Então, sob o qual [Heading] devemos colocá-lo? - underscore_d
No meu caso, foi AutoEnable = false, mas de qualquer maneira +1 para a solução certa do lugar certo. - Arman Petrosyan


Para desativar o carregamento do driver bluetooth na inicialização:

sudo $EDITOR /etc/modprobe.d/blacklist.conf

adicionar:

blacklist btusb

A ativação posterior deve ser apenas:

sudo modprobe btusb

23
2017-08-18 16:59



Obrigado por isso, isso parece funcionar, mas eu estava tentando evitar coisas de linha de comando de acordo com a minha pergunta original. Você poderia pensar que isso seria tão simples quanto marcar uma caixa para que ela se lembre de que eu não quero que a BT inicie automaticamente, mas parece que é mais complicado do que isso. Com o impulso do Ubuntu para tempos de inicialização mais rápidos e o foco geral no consumo de energia em laptops e netbooks, estou surpreso que isso nunca tenha sido resolvido. Eu agradeço a ajuda embora.
"Execute gedit como root e edite /etc/modprobe.d/blacklist.conf" <- ok, essa linha de comando é menor para você? - maco
Funciona bem no Samsung Q35 com o Ubuntu 13.10, enquanto a abordagem 'rfkill block bluetooth' não. Obrigado! - user27164
DELL E6410 funciona para mim. Bom que pode rodar novamente em movimento sem resetar. - Ruslan Gerasimov
Não se preocupe em tentar "evitar coisas de linha de comando" quando estiver configurando o sistema operacional. É Ctrl + Alt + T e um par de ctrl-shift-V (para colar) demais para perguntar? - doug65536


Passo 1: Vá para o terminal e digite o seguinte comando para editar o sistema /etc/rc.local Arquivo:

gksudo gedit /etc/rc.local

Etapa 2: adicione a seguinte linha antes do exit 0 linha:

rfkill block bluetooth

16
2018-05-04 20:44



Isso é definido bloco macio para bluetooth, acho que mesmo que desligar o serviço e funciona bem. - Smile.Hunter
@Robert: $ man rfkill: "Desativar o dispositivo correspondente ao índice fornecido."Apesar do nome, é só desabilitar o BT; basta tentar o comando rfkill block bluetooth no terminal, você deve ver o ícone ficar cinza. - Daniel


A partir do 16.04 do ubuntu, o systemd gerencia serviços de inicialização como o bluetooth ... para ver o problema de status atual seguindo um terminal

sudo systemctl status bluetooth.service 

para desativar o bluetooth na inicialização deste problema

sudo systemctl disable bluetooth.service

então na próxima reinicialização o bluetooth não estará ativo ... para habilitar o problema do bluetooth

sudo systemctl enable bluetooth.service

12
2017-08-01 15:08



Isso funciona para mim, mas como um efeito colateral, o applet blueman parou de funcionar também. Ele começa, mas não aparece na área do indicador, portanto, não há maneira rápida de ativar o bluetooth, apenas no terminal. - Yuri Gor
No Xubuntu, pelo menos, se você clicar no Blueman, ele tem a opção de "Desligar o Bluetooth". Eu acho que isso é o que o OP gostaria de automatizar. Sua solução remove o Blueman completamente, dificultando a reativação do Bluetooth, se desejado. - Adrian Keister
Coloque sudo systemctl disable bluetooth.service && sudo systemctl stop bluetooth.service em um script Disable, e chmod 755 nele. Faça o mesmo para sudo systemctl enable bluetooth.service && sudo systemctl start bluetooth.service em um script Enable. - Adrian Keister


Digite o seguinte em um terminal:

sudo gedit /etc/modprobe.d/blacklist.conf

Na parte inferior do arquivo, adicione a linha:

blacklist bluetooth

Salve o arquivo e reinicie - o Bluetooth agora deve estar desativado.


7
2017-10-16 21:25



Isso não vai funcionar no meu pc ... - Floqqi
@Floqqi: Você pode por favor tentar de novo? Eu atualizei minha resposta. - Nathan Osman
Tentei cerca de 20 coisas no meu thinkpad do Ubuntu 12, este é o único que fez o truque. - OlivierBlanvillain


Você pode alterar os serviços iniciados na inicialização com a ajuda de VAGABUNDO.

Instale-o: sudo apt-get install bum

Corre: sudo bum

enter image description here 

Desmarque a caixa e clique em Aplique.


7
2018-05-05 00:09



Obrigada, desgua, estava pensando nesse tipo de ferramentas. Eu usei alguns no passado, mas eles se tornaram obsoletos e o novo Ubuntu, com sua obsessão minimalista, não vem com nada disso. Isso é o único que você sabe ou o melhor que você sabe? - Robert
Talvez funcione, mas no começo ele me desapontou porque começou a mostrar o bluetooth como não ativado na inicialização, por quê? e como não rodando quando o rfkill, o applet e o hciconfig mostram ele rodando. Desligo e acendo, mas o bum continua mostrando o serviço como desligado. Ativei o serviço na inicialização, mas o status do serviço continua errado. - Robert
desculpe não funciona no elementaryOS Freya - Hoang Tran
Eu recebo muitos avisos de "uso de valor não inicializado" quando é executado. Desculpe, não posso confiar nisso. - doug65536
Agora, o pacote não está disponível. Dizem que o Bum é virtual. - Satya Prakash