Questão Ubuntu 12.04 LTS Network Icon Mistaken


Depois de algum processo de diagnóstico, descobri que minha rede sem fio ainda não foi resolvida, mas minha conexão com fio enganou o ícone errado.

eth0      Link encap:Ethernet  HWaddr 20:6a:8a:3f:70:90  
          inet addr:172.29.2.181  Bcast:172.29.15.255  Mask:255.255.240.0
          inet6 addr: fe80::226a:8aff:fe3f:7090/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3328 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1414 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1324723 (1.3 MB)  TX bytes:260711 (260.7 KB)
          Interrupt:19 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:79866 errors:0 dropped:0 overruns:0 frame:0
          TX packets:79866 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:10583710 (10.5 MB)  TX bytes:10583710 (10.5 MB)

WARNING: you should run this program as super-user.
  *-network UNCLAIMED     
       description: Network controller
       product: AR9287 Wireless Network Adapter (PCI-Express)
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: cap_list
       configuration: latency=0
       resources: memory:f1600000-f160ffff
  *-network
       description: Ethernet interface
       product: NetLink BCM57785 Gigabit Ethernet PCIe
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:04:00.0
       logical name: eth0
       version: 10
       serial: 20:6a:8a:3f:70:90
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: bus_master cap_list rom ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.123 duplex=full firmware=sb ip=172.29.2.181 latency=0 multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:19 memory:f1400000-f140ffff memory:f1410000-f141ffff memory:f1450000-f14507ff

AVISO: a saída pode estar incompleta ou imprecisa, você deve executar este programa como superusuário.

Qualquer um pode ajudar?

De acordo com o Chili555, eu tentei modprobe ath9k && dmesg | grep ath

[339970.692404] ath: phy0: Chip reset failed
[339970.692409] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[339970.809499] ath: phy0: Chip reset failed
[339970.809504] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[339970.925151] ath: phy0: Chip reset failed
[339970.925156] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[340612.711783] ath: phy0: Chip reset failed
[340612.711789] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[340612.829633] ath: phy0: Chip reset failed
[340612.829639] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[340612.945773] ath: phy0: Chip reset failed
[340612.945779] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[340626.001522] ath: phy0: Chip reset failed
[340626.001527] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[346785.942351] ath: phy0: Chip reset failed
[346785.942356] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[346786.059931] ath: phy0: Chip reset failed
[346786.059936] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[346786.176004] ath: phy0: Chip reset failed
[346786.176009] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[347318.499218] ath: phy0: Chip reset failed
[347318.499224] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[347335.167438] ath: phy0: Chip reset failed
[347335.167444] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[347335.284839] ath: phy0: Chip reset failed
[347335.284845] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[347335.400957] ath: phy0: Chip reset failed
[347335.400962] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[348371.939924] ath: phy0: Chip reset failed
[348371.939929] ath: phy0: Unable to reset hardware; reset status -22 (freq 2412 MHz)
[349456.895035] ath9k: ath9k: Driver unloaded
[349465.420567] ath9k 0000:03:00.0: enabling device (0000 -> 0002)
[349465.535474] ath: phy1: Couldn't reset chip
[349465.535478] ath: phy1: Unable to initialize hardware; initialization status: -5
[349465.535484] ath9k 0000:03:00.0: Failed to initialize device
[349465.535575] ath9k: probe of 0000:03:00.0 failed with error -5
[349648.631049] ath9k: ath9k: Driver unloaded
[349658.068003] ath: phy2: Couldn't reset chip
[349658.068008] ath: phy2: Unable to initialize hardware; initialization status: -5
[349658.068014] ath9k 0000:03:00.0: Failed to initialize device
[349658.068066] ath9k: probe of 0000:03:00.0 failed with error -5
[427830.275860] ath9k: ath9k: Driver unloaded
[427833.430991] ath: phy3: Couldn't reset chip
[427833.431006] ath: phy3: Unable to initialize hardware; initialization status: -5
[427833.431023] ath9k 0000:03:00.0: Failed to initialize device
[427833.431280] ath9k: probe of 0000:03:00.0 failed with error -5
[428873.448746] ath9k: ath9k: Driver unloaded
[429026.303871] ath: phy4: Couldn't reset chip
[429026.303877] ath: phy4: Unable to initialize hardware; initialization status: -5
[429026.303882] ath9k 0000:03:00.0: Failed to initialize device
[429026.303969] ath9k: probe of 0000:03:00.0 failed with error -5
[429088.070481] ath9k: ath9k: Driver unloaded
[429115.975556] ath: phy5: Couldn't reset chip
[429115.975560] ath: phy5: Unable to initialize hardware; initialization status: -5
[429115.975565] ath9k 0000:03:00.0: Failed to initialize device
[429115.975616] ath9k: probe of 0000:03:00.0 failed with error -5

1
2017-12-18 12:44


origem


Por favor, edite sua pergunta para adicionar o resultado destes comandos de terminal: sudo modprobe ath9k e também: dmesg | grep ath - chili555
ESTÁ BEM. Eu adicionei na minha seção de perguntas principais, devido às estritas propriedades da página no comentário. Muito obrigado. - Laurent
Adicione também: uname -r. Existem várias versões 12.04 LTS, todas usando kernels diferentes. Minha correção sugerida depende do seu kernel. - chili555
3.5.0-44-generic, esta é a minha versão atual do linux. - Laurent


Respostas:


Eu sugiro que você instale uma versão posterior do driver ath9k. Com uma conexão ethernet com fio, abra um terminal e faça:

sudo apt-get install linux-backports-modules-cw-3.12-precise-generic

Reinicie e deixe-nos ouvir seu relatório. Se não estiver funcionando como esperado, vamos ver:

dmesg | grep ath

2
2017-12-18 23:35



Muito obrigado! Funcionou depois que eu reiniciei meu computador. Desculpe por este atraso da minha resposta, o trabalho de cálculo não admite uma reinicialização. Depois de tudo funcionou normal, eu também tentei o comando demsg | grep ath, e o que eu recebi é: (desculpe, eu tenho que cortar essa mensagem) [4.248277] ath :: EEPROM regdomain: 0.65, ...., [150.693146] ath9k: ath9k: Driver descarregado. Estou muito feliz que minha placa wlan funcione, mas você acha que esta mensagem é normal? - Laurent
Não vejo nada anormal ou anormal aqui. Estou feliz que esteja funcionando. Por favor aceite minha resposta. - chili555
ESTÁ BEM. Porque mostra que um ath9k: driver descarregou, e mostra outra coisa, então eu me preocupei que ... Claro, eu vou aceitar sua resposta, você me ajudou muito. Muito obrigado, chili555. :))) - Laurent