Questão Sobre o repositório


Meu Repositório não pode ser atualizado algum item, por favor me ajude

W: Failed to fetch http://ppa.launchpad.net/elementary-br/projects/ubuntu/dists/oneiric/main/source/Sources  404  Not Found
W: Failed to fetch http://ppa.launchpad.net/elementary-br/projects/ubuntu/dists/oneiric/main/binary-i386/Packages  404  Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.
E: Could not get lock /var/lib/dpkg/lock - open (11: Resource temporarily unavailable)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

entende ?


1
2017-12-23 19:49


origem




Respostas:


Se você for ao site, verá que não há fontes para a distro onírica:

http://ppa.launchpad.net/elementary-br/projects/ubuntu/dists/

Apenas precisa, quantal e rara.

Você tem duas opções:

  1. Remova esse repositório (não acho que você queira fazer isso se você o adicionou manualmente).
  2. Edite o arquivo que contém o repositório e altere todas as referências oníricas para a distribuição real que você está usando (que, a propósito, você poderia dizer na sua pergunta).

O arquivo está em /etc/apt/sources.list.d/ (não tenho certeza sobre o nome) e você pode editá-lo assim:

gksu gedit /tc/apt/sources.list.d/nameofthefile.list

Lá, mude onírico para o nome da sua distro.

Se a sua distro é onírica, então você não pode usar este ppa como fonte, você precisará removê-la de suas fontes, excluindo o arquivo que faz referência a ela.


2
2017-12-23 19:56