Questão Não é possível instalar o sdk do Ubuntu


Enquanto instala sudo apt-get install ubuntu-sdk, Estou enfrentando isso Os seguintes pacotes possuem dependências não atendidas:

ubuntu-sdk : Depends: qtcreator-plugin-ubuntu-cordova but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

1
2017-12-27 19:57


origem


possível duplicata de Como resolvo dependências não satisfeitas depois de adicionar um PPA? - Tim


Respostas:


ubuntu-sdk depende de qtcreator-plugin-ubuntu-cordova. Últimas necessidades cordova-ubuntu-2.8, cordova-ubuntu-2.8-dev, qtcreator-plugin-ubuntu, qtcreator-plugin-ubuntu-cordova-common.

Esse problema de dependência não atendida poderia ter sido despertado, porque qtcreator-plugin-ubuntu-cordova não pode ser instalado.

Então corra:

sudo apt-get install ubuntu-sdk qtcreator-plugin-ubuntu-cordova cordova-ubuntu-2.8 cordova-ubuntu-2.8-dev qtcreator-plugin-ubuntu qtcreator-plugin-ubuntu-cordova-common

2
2017-12-27 20:46