Questão Instalação autônoma do phpmyadmin acaba gerando erros


Estou tentando instalar o phpmyadmin pré-configurando as informações através do comando debconf-set-selection no meu Ubuntu 12.04LTS

Essa é a parte que estou usando

echo phpmyadmin phpmyadmin/dbconfig-install boolean true | debconf-set-selections
echo phpmyadmin phpmyadmin/app-password-confirm password pwd | debconf-set-selections
echo phpmyadmin phpmyadmin/mysql/admin-pass password pwd| debconf-set-selections
echo phpmyadmin phpmyadmin/mysql/app-pass password pwd| debconf-set-selections
echo phpmyadmin phpmyadmin/reconfigure-webserver multiselect apache2 | debconf-set-selections
echo phpmyadmin phpmyadmin/upgrade-backup boolean true | debconf-set-selections

Mas eu sempre acabo recebendo a seguinte mensagem de erro

error: Cannot find a question for phpmyadmin/dbconfig-install
error: Cannot find a question for phpmyadmin/app-password-confirm
error: Cannot find a question for phpmyadmin/mysql/admin-pass
error: Cannot find a question for phpmyadmin/mysql/app-pass
error: Cannot find a question for phpmyadmin/upgrade-backup

se eu tentar executar o comando usando o sudo do shell, recebo a seguinte mensagem

debconf: DbDriver "passwords" warning: could not open /var/cache/debconf/passwords.dat: Permission denied

No entanto, eu já consegui instalar isso. Então, qual poderia ser a causa?

obrigado Andrea


1
2018-01-04 10:13


origem




Respostas:


Isto pode estar relacionado com um erro do debconf: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=487300

Seu banco de dados debconf pode ter sido corrompido.

Corrida /usr/share/debconf/fix_db.pl pode consertar isso.

Espero que funcione para você.


2
2018-01-21 13:36



Impressionante. Este comando funcionou muito bem! - Leon