Questão quando eu tento instalar qualquer coisa no Ubuntu 12.04 eu recebo este erro


sudo apt-get install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies: libjson0 : Breaks: libjson0:i386 (!= 0.10-1.2ubuntu2) but 0.9-1ubuntu1 is installed libjson0:i386 : Breaks: libjson0 (!= 0.9-1ubuntu1) but 0.10-1.2ubuntu2 is installed
teamviewer : Depends: lib32asound2 but it is not installed
          Depends: lib32z1 but it is not installed
E: Unmet dependencies. Try using -f.

Alguém pode me ajudar com isso?


1
2018-01-21 06:24


origem


você tentou correr sudo apt-get -f install como diz? - c0rp
sim eu fiz isso mas recebi erro como dpkg: erro processando libjson0: i386 (--configure): libjson0: i386 0.9-1ubuntu1 não pode ser configurado porque libjson0: amd64 está em uma versão diferente (0.10-1.2ubuntu2) dpkg: processamento de erro libjson0 (--configure): libjson0: amd64 0.10-1.2ubuntu2 não pode ser configurado porque libjson0: i386 está em uma versão diferente (0.9-1ubuntu1) Foram encontrados erros durante o processamento: libjson0: i386 libjson0 E: Subprocesso / usr / bin / dpkg retornou um código de erro (1) - user238169
Leia isso askubuntu.com/questions/171205/… - c0rp


Respostas:


Você tem que remover o particular libjson0,libjson0:i386 pacotes forçados sem remover suas dependências,

sudo dpkg --purge --force-all --force-remove-reinstreq libjson0 libjson0:i386
sudo apt-get -f install

2
2018-01-21 07:13





Senhor... você deve digitar esses comandos

apt-get -f install

Se isso não funcionar, tente fazer isso

sudo apt-get clean
sudo apt-get remove libjson0:i386
sudo apt-get install libjson0
sudo apt-get install lib32asound2
sudo apt-get install lib32z1

se o comando sudo apt-get remove libjson0:i386 não funcionou ir para a próxima ou instalá-lo com o gerenciador de pacotes synapatic

* procure em traço    Aqui


0
2018-01-21 06:43