Questão Como mudar o driver da placa gráfica via terminal?


Eu recentemente tentei mudar o driver para o meu Asus Radeon HD 7870 para o proprietário (um amigo me disse que era muito mais rápido), no entanto, que parece ter matado a minha instalação do Ubuntu. Agora, sempre que eu inicializo, ele me mostra o GRUB, eu seleciono o Ubuntu e, em seguida, ele inicializa por um segundo ou dois e, em seguida, em telas negras. Eu acho que a tela preta é causada por ela atingir a tela de login, pois também é nesse ponto que eu posso conectar o SSH nela.

Então alguém pode me dizer como voltar para o driver de código aberto?

Edit: E eu vou adicionar, quando eu inicializar Ubuntu fora de um USB, tudo funciona bem.

Edit: Ok aqui meu processo é para o motorista.

  1. Instale a Radeon HD 7870 no meu sistema
  2. Arranque, tudo está funcionando bem automaticamente
  3. Eu vou verificar e ele está usando o driver de código aberto (eu chequei indo para o programa de software e atualizações e indo para a guia do driver)
  4. Um amigo recomenda que eu mude para o proprietário, pois é mais rápido (eu acredito que foi algo ao longo das linhas de atualizações flgrx)
  5. Entro no programa Software and Updates e navegue até a guia drivers. De lá eu selecionei o flgrx-updates one e cliquei ok.
  6. Eu reinicio o meu sistema e depois não funciona. Depois de alguns problemas básicos, eu venho aqui.

Update: Graças a gertvdijk eu consegui desativar o driver proprietário, mas o Ubuntu ainda não vai bater. Eu estou supondo que, por qualquer motivo, o driver de código aberto não foi ativado automaticamente. Alguém tem alguma ideia? Existe algum log do sistema que eu possa dar a vocês para ajudar a encontrar o problema?


12
2017-07-13 17:32


origem


Ainda acontecendo no ubuntu v14 :( - w00t
Você conseguiu consertar isso? Eu tentei ambos os drivers e acho que algo foi quebrado, porque agora, isso acontece aleatoriamente ... - Peter Raeves
@PeterRaeves Como eu disse abaixo, acabei apenas reinstalando a partição do sistema e isso resolveu. - scaru
@scaru Da próxima vez que isso acontecer com você, tente limpar, instalar e reconfigurar o xserver-xorg. Isso é o que fez o truque para mim. - Peter Raeves
Eu tive o mesmo problema no ubuntu 16.04 desktop, apenas com drivers da nvidia, mas no final a história é a mesma: não consegui logar via modo gráfico, apenas a partir do console de texto ... o que resolveu o problema foi exatamente isso: purgar e a instalação novamente do pacote xserver-xorg - Luke


Respostas:


Para 14.04 e superior, o texto jockey não está instalado ou disponível no repositório. Acabei de me recuperar de um problema em que o driver do Noveau fez com que meu computador travasse completamente após o login e precisei voltar ao driver nvidia. Veja como eu fiz:

Na tela de login, em vez de fazer o login, fui a um terminal usando CRL + ALT + F2 Tipo

dispositivos ubuntu-drivers

para obter uma lista dos seus dispositivos e identificar o que você deseja. Minha saída ficou assim:

dispositivos $ ubuntu-drivers
  == /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
   modalias: pci: v000010DEd00000391sv00001462sd00000630bc03sc00i00
   fornecedor: NVIDIA Corporation
   modelo: G73 [GeForce 7600 GT]
   driver: nvidia-304 - distro não-livre recomendado
   motorista: nvidia-173 - distro non-free
   driver: xserver-xorg-video-nouveau - distro grátis
   driver: nvidia-304-updates - distro não-livre

Eu queria nvidia-304 então eu digitei:

apt-get instala nvidia-304

Então eu reiniciei e confirmei usando os drivers adicionais do desktop appliaction que eu estava realmente usando o driver que eu tinha escolhido.


5
2018-06-07 21:27





Para desinstalar os drivers proprietários, você deve poder simplesmente fazer:

sudo apt-get remove fglrx   fglrx-amdcccle fglrx-pxpress 

se você instalou os drivers padrão ou

sudo apt-get remove fglrx-updates   fglrx-amdcccle-updates 

se você tiver o "atualizações".

Lembrar para excluir manualmente o arquivo /etc/X11/xorg.conf; caso contrário, o X ainda procurará pelos drivers proprietários e não iniciará corretamente (na maioria das vezes).

Isso normalmente reativaria os drivers padrão (código aberto).


3
2018-01-08 03:29





Eu só queria falar aqui porque eu tinha exatamente o mesmo problema (rodando o Ubuntu 14.04 LTS). Selecionei um driver de placa de vídeo diferente nas configurações do sistema e, após a reinicialização, o computador solicitou que eu iniciasse no modo de baixa resolução.

O que resolveu o problema para mim foi excluir o /etc/X11/xorg.conf. Agora, o X11 é o gerenciador de janelas usado pelo Ubuntu, e ele carrega todos os arquivos terminados em .conf para suas configurações (pelo menos - isso é o que três minutos do Google me disseram).

Como eu hesitaria em remover completamente os arquivos que, em retrospecto, poderiam ser essenciais, renomei para outra coisa:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
sudo reboot

Isso resolveu o problema para mim.

Inicialmente, minha ideia era usar a linha de comando para alterar o driver da placa de vídeo. Eu recorri a tentar essa idéia porque não conseguia encontrar uma maneira de mudar o driver da placa de vídeo. Uma resposta sugerida dizia para usar jockey-text (Como alterar o driver de vídeo proprietário usando a linha de comando?); no entanto, começando com 14.04 jockey-text não faz mais parte do Ubuntu.

Alguma pesquisa adicional: Eu li que o X11 não cria mais um xorg.conf por padrão. A solução acima pode não funcionar para você.


2
2018-01-07 07:48



+1 para provável resposta relevante; O conteúdo de xorg.conf arquivo seria diferente, dependendo de qual driver em uso. Por padrão, esse arquivo realmente não existe em 14.04. Executar a configuração gráfica proprietária pela primeira vez provavelmente gerará xorg.conf arquivo automaticamente (nvidia-settings isso pode ser semelhante para o caso AMD / Radeon). - clearkimura


Depois de ninguém dar respostas adicionais por 2 dias, decidi reinstalar o Ubuntu. Eu criei um Ubuntu USB ao vivo, e usando isso disse para reinstalar o Ubuntu (substitui arquivos do sistema, mas mantém meus arquivos), e isso funcionou perfeitamente.


1
2017-07-16 01:00



É muito triste que a solução seja reinstalar o sistema operacional. - haventchecked


Executar por SSH:

jockey-text --list

em seguida, identifique o driver que você deseja desativar e executar

sudo jockey-text --disable driveridentification

Substituir driveridentification com o ID que seu motorista mostra com (por exemplo, xorg:nvidia_experimental_310 No meu caso). Eu não consigo testar / verificar isso no momento.

jockey-text é a versão somente de texto da linha de comando do aplicativo "drivers adicionais" na GUI normal. Você deve ser capaz de executar as mesmas tarefas que no aplicativo GUI normal - veja a ajuda em outras tarefas:

jockey-text --help

Isso funcionará no seu caso, já que você diz que ainda pode fazer login usando o SSH. Para outros leitores que não configuraram o SSH em sua máquina, eles precisarão inicializar no modo de recuperação ou colocar em blacklist o módulo do kernel do driver de gráficos na linha de comando do Grub e então executar as mudanças do jockey.


0
2017-07-13 17:35



Acabei de executar esse comando, por SSH. Então me disse que eu tinha que instalar jockey-commons, então eu fiz isso. Então eu corri de novo. Isso é o que eu recebi: root@david-desktop:~# jockey-text Additional Drivers Searching for available drivers... root@david-desktop:~# - scaru
@scaru Então eu suponho que você não tenha instalado o driver Radeon usando o aplicativo "Drivers adicionais"? Por favor, inclua todos os detalhes sobre como você instalou o driver em primeiro lugar na sua pergunta (edite-o!). Se este for o caso que invalida a minha resposta - por favor, seja mais específico na sua próxima pergunta! - gertvdijk
ok eu atualizei minha pergunta original com mais detalhes. Mas sim, eu mudei o driver dentro da guia Drivers adicionais do aplicativo Software and Updates. - scaru
@scaru Desculpe a minha resposta estar errada - eu erroneamente assumi que esta era uma aplicação interativa. Deixe-me atualizá-lo. - gertvdijk
ok eu apenas tentei executar o jockey-text --list e recebi isto: root@david-desktop:~# jockey-text --list kmod:fglrx - Video driver for the AMD graphics accelerators (Proprietary, Disabled, Not in use) kmod:fglrx_updates - ATI Fire GL (Proprietary, Enabled, Not in use) root@david-desktop:~#    Portanto, não está listando o driver de código aberto por qualquer motivo. - scaru